summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-25 01:33:58 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-25 01:33:58 +0000
commit553062f83e9f3a7cc4d0d689b7152e85244c7061 (patch)
treeedc9c21547c6bde990179c2df51691f857b643c4 /dev-libs/xapian-bindings/files
parent3.1.3 version bump. Marking 3.0.1 x86 stable. (diff)
downloadhistorical-553062f83e9f3a7cc4d0d689b7152e85244c7061.tar.gz
historical-553062f83e9f3a7cc4d0d689b7152e85244c7061.tar.bz2
historical-553062f83e9f3a7cc4d0d689b7152e85244c7061.zip
Version bump with new ruby bindings. Now also builds the java bindings if requested. Ebuild cleanup based on suggestions from Olly Betts (<olly@survex.com>).
Package-Manager: portage-2.1_rc2-r2
Diffstat (limited to 'dev-libs/xapian-bindings/files')
-rw-r--r--dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.63
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch22
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch13
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch10
-rw-r--r--dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch97
5 files changed, 145 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6 b/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6
new file mode 100644
index 000000000000..753185edcf3c
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/digest-xapian-bindings-0.9.6
@@ -0,0 +1,3 @@
+MD5 f404b6a9c9e86a9ec6dfbbe38909b2cf xapian-bindings-0.9.6.tar.gz 792703
+RMD160 7320856c454e8ba675d168baccb92be022e2a24e xapian-bindings-0.9.6.tar.gz 792703
+SHA256 758765bde18817a7e4fde5d21742be5fb154f77ba211fe93d3dd00523e1657ed xapian-bindings-0.9.6.tar.gz 792703
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch
new file mode 100644
index 000000000000..13b1aa79ce73
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-java-array-delete.patch
@@ -0,0 +1,22 @@
+Index: native/Query.cc
+===================================================================
+--- native/Query.cc (revision 6993)
++++ native/Query.cc (working copy)
+@@ -110,7 +110,7 @@
+ jsize size = env->GetArrayLength(terms);
+ string *array = toArray(env, terms, size);
+ Query *q = new Query(op_table[op-1], array, array+size);
+- delete array;
++ delete[] array;
+ return _query->put(q);
+ CATCH(-1)
+ }
+@@ -124,7 +124,7 @@
+ queries[x] = _query->get(qid_ptr[x]);
+ }
+ Query *q = new Query(op_table[op-1], queries, queries+len);
+- delete queries;
++ delete[] queries;
+ return _query->put(q);
+ CATCH(-1)
+ }
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch
new file mode 100644
index 000000000000..882b0dd0daca
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-parallel-make.patch
@@ -0,0 +1,13 @@
+=== modified file 'python/Makefile.am'
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -49,7 +49,7 @@
+ # the .py file to the build directory instead. We "import _xapian" first
+ # so that if we fail to import the glue library we don't generate a broken
+ # xapian.pyc.
+-xapian.pyc: xapian.py
++xapian.pyc: xapian.py _xapian.la
+ PYTHONPATH=".$(PYTHON_PATHSEP).libs" $(PYTHON) -c "import _xapian;import xapian"
+
+ xapian.py: @PYTHON_MODERN_OR_OLDE@/xapian.py
+
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch
new file mode 100644
index 000000000000..fd43d7f39bfc
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests-2.patch
@@ -0,0 +1,10 @@
+--- smoketest5.php.orig 2006-05-24 17:31:13.000000000 +0200
++++ smoketest5.php 2006-05-24 17:37:19.000000000 +0200
+@@ -26,6 +26,6 @@
+ print "Retrieved non-existent document\n";
+ exit(1);
+ }
+-} catch (e) {
++} catch (Exception $e) {
+ }
+ ?>
diff --git a/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch
new file mode 100644
index 000000000000..ce5a2bd9c3c1
--- /dev/null
+++ b/dev-libs/xapian-bindings/files/xapian-bindings-0.9.6-php-tests.patch
@@ -0,0 +1,97 @@
+Index: smoketest.php
+===================================================================
+--- smoketest.php (revision 7002)
++++ smoketest.php (working copy)
+@@ -108,17 +108,7 @@
+ exit(1);
+ }
+
+-# Check PHP4 handling of Xapian::DocNotFoundError
+-$old_error_reporting = error_reporting();
+-if ($old_error_reporting & E_WARNING)
+- error_reporting($old_error_reporting ^ E_WARNING);
+-$doc2 = Database_get_document($db, 2);
+-if ($doc2 != null) {
+- print "Retrieved non-existent document\n";
+- exit(1);
+-}
+-if ($old_error_reporting & E_WARNING)
+- error_reporting($old_error_reporting);
++include "smoketest".substr(PHP_VERSION, 0, 1).".php";
+
+ # Regression test - overload resolution involving boolean types failed.
+ Enquire_set_sort_by_value($enq, 1, TRUE);
+Index: smoketest4.php
+===================================================================
+--- smoketest4.php (revision 0)
++++ smoketest4.php (revision 0)
+@@ -0,0 +1,33 @@
++<?php
++/* PHP4 specific tests.
++ *
++ * Copyright (C) 2006 Olly Betts
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
++ * USA
++ */
++
++# Check PHP4 handling of Xapian::DocNotFoundError
++$old_error_reporting = error_reporting();
++if ($old_error_reporting & E_WARNING)
++ error_reporting($old_error_reporting ^ E_WARNING);
++$doc2 = Database_get_document($db, 2);
++if ($doc2 != null) {
++ print "Retrieved non-existent document\n";
++ exit(1);
++}
++if ($old_error_reporting & E_WARNING)
++ error_reporting($old_error_reporting);
++?>
+Index: smoketest5.php
+===================================================================
+--- smoketest5.php (revision 0)
++++ smoketest5.php (revision 0)
+@@ -0,0 +1,31 @@
++<?php
++/* PHP5 specific tests.
++ *
++ * Copyright (C) 2006 Olly Betts
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU General Public License as
++ * published by the Free Software Foundation; either version 2 of the
++ * License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301
++ * USA
++ */
++
++# Check PHP5 handling of Xapian::DocNotFoundError
++try {
++ $doc2 = Database_get_document($db, 2);
++ if ($doc2 != null) {
++ print "Retrieved non-existent document\n";
++ exit(1);
++ }
++} catch (e) {
++}
++?>