summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2011-01-07 23:37:13 +0000
committerRyan Hill <rhill@gentoo.org>2011-01-07 23:37:13 +0000
commit3b08a3f1df4e0305bd91a0b229ee48cb402d2360 (patch)
tree473153a5758826fedf11b2c8052100a484cbe668 /dev-libs/ppl
parentMarking recode-3.6_p17-r2 ppc for bug 350960 (diff)
downloadhistorical-3b08a3f1df4e0305bd91a0b229ee48cb402d2360.tar.gz
historical-3b08a3f1df4e0305bd91a0b229ee48cb402d2360.tar.bz2
historical-3b08a3f1df4e0305bd91a0b229ee48cb402d2360.zip
Version bump. (bug #345679)
Package-Manager: portage-2.1.9.30/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/ppl')
-rw-r--r--dev-libs/ppl/ChangeLog9
-rw-r--r--dev-libs/ppl/ppl-0.11.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/dev-libs/ppl/ChangeLog b/dev-libs/ppl/ChangeLog
index def0d82a4b4f..71c82015314d 100644
--- a/dev-libs/ppl/ChangeLog
+++ b/dev-libs/ppl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ppl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.29 2010/11/21 06:24:07 dirtyepic Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ChangeLog,v 1.30 2011/01/07 23:37:13 dirtyepic Exp $
+
+*ppl-0.11 (07 Jan 2011)
+
+ 07 Jan 2011; Ryan Hill <dirtyepic@gentoo.org> +ppl-0.11.ebuild:
+ Version bump. (bug #345679)
21 Nov 2010; Ryan Hill <dirtyepic@gentoo.org> -ppl-0.10.2.ebuild,
ppl-0.10.2-r1.ebuild, -files/ppl-0.10.2-gmp-5-fix.patch, metadata.xml:
diff --git a/dev-libs/ppl/ppl-0.11.ebuild b/dev-libs/ppl/ppl-0.11.ebuild
new file mode 100644
index 000000000000..038e2a319bfd
--- /dev/null
+++ b/dev-libs/ppl/ppl-0.11.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ppl/ppl-0.11.ebuild,v 1.1 2011/01/07 23:37:13 dirtyepic Exp $
+
+EAPI="3"
+
+DESCRIPTION="The Parma Polyhedra Library provides numerical abstractions for analysis of complex systems"
+HOMEPAGE="http://www.cs.unipr.it/ppl/"
+SRC_URI="http://www.cs.unipr.it/ppl/Download/ftp/releases/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="doc lpsol pch test watchdog"
+
+RDEPEND=">=dev-libs/gmp-4.1.3[-nocxx]
+ lpsol? ( sci-mathematics/glpk )
+ !<dev-libs/cloog-ppl-0.15.10"
+DEPEND="${RDEPEND}
+ sys-devel/m4"
+
+pkg_setup() {
+ if use test; then
+ ewarn "The PPL testsuite will be run."
+ ewarn "Note that this can take several hours to complete on a fast machine."
+ epause 3
+ fi
+}
+
+src_configure() {
+ # --disable-check doesn't work
+ use test && want_check="--enable-check=quick"
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-debugging \
+ --disable-optimization \
+ $(use_enable lpsol ppl_lpsol) \
+ $(use_enable pch) \
+ $(use_enable watchdog) \
+ --enable-interfaces="c cxx" \
+ ${want_check} \
+ || die "configure failed"
+}
+
+src_test() {
+ # default src_test runs with -j1, overriding it here saves about
+ # 30 minutes and is recommended by upstream
+ if emake -j1 check -n &> /dev/null; then
+ emake check || die "tests failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed install"
+
+ local docsdir="${ED}/usr/share/doc/${PF}"
+ rm "${docsdir}"/gpl* "${docsdir}"/fdl* || die "Failed removing licenses"
+
+ if ! use doc; then
+ rm -r "${docsdir}"/*-html/ || die "Failed removing docs"
+ fi
+
+ dodoc NEWS README* STANDARDS TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "After an upgrade of PPL it is important that you rebuild"
+ ewarn "dev-libs/cloog-ppl."
+ ewarn
+ ewarn "If you use gcc-config to switch to an older compiler version than"
+ ewarn "the one PPL was built with, PPL must be rebuilt with that version."
+ ewarn
+ ewarn "In both cases failure to do this will get you this error when"
+ ewarn "graphite flags are used:"
+ ewarn
+ ewarn " sorry, unimplemented: Graphite loop optimizations cannot be used"
+ ewarn
+ echo
+}