summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-10 14:16:23 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-10 14:16:23 +0000
commit047ae119d3481c43d990926dadf02f84daa57fb3 (patch)
treee254ec125c5d74f15f38b85699bb8a7356f552a0 /dev-libs/msgpack/msgpack-0.5.6.ebuild
parentMasked net-mail/cyrus-imapd-2.4.8 Needs some testing first. (diff)
downloadhistorical-047ae119d3481c43d990926dadf02f84daa57fb3.tar.gz
historical-047ae119d3481c43d990926dadf02f84daa57fb3.tar.bz2
historical-047ae119d3481c43d990926dadf02f84daa57fb3.zip
Version bumped. Added static-libs USE flag.
Package-Manager: portage-2.1.9.46/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/msgpack/msgpack-0.5.6.ebuild')
-rw-r--r--dev-libs/msgpack/msgpack-0.5.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/msgpack/msgpack-0.5.6.ebuild b/dev-libs/msgpack/msgpack-0.5.6.ebuild
new file mode 100644
index 000000000000..c783469c0bf2
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/msgpack/msgpack-0.5.6.ebuild,v 1.1 2011/05/10 14:16:23 matsuu Exp $
+
+EAPI="3"
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="http://msgpack.org/"
+SRC_URI="http://msgpack.org/releases/cpp/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="static-libs test"
+
+DEPEND="test? ( dev-util/gtest )"
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -exec rm {} +
+ fi
+ dodoc AUTHORS ChangeLog NEWS README || die
+}