summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-01-19 05:19:29 +0000
committerRyan Hill <rhill@gentoo.org>2010-01-19 05:19:29 +0000
commit216d6e99322ad81f8630cda9b1127d743000bd08 (patch)
tree89cb76ec8b58a828f2d207aad02df67bf6e8c08d /dev-libs/mpc/mpc-0.8.1.ebuild
parentEAPI=2 version of 1.3.0 that fixes building of saa717x driver. fix elog/ewarn... (diff)
downloadhistorical-216d6e99322ad81f8630cda9b1127d743000bd08.tar.gz
historical-216d6e99322ad81f8630cda9b1127d743000bd08.tar.bz2
historical-216d6e99322ad81f8630cda9b1127d743000bd08.zip
Version bump, drop old.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/mpc/mpc-0.8.1.ebuild')
-rw-r--r--dev-libs/mpc/mpc-0.8.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/mpc/mpc-0.8.1.ebuild b/dev-libs/mpc/mpc-0.8.1.ebuild
new file mode 100644
index 000000000000..c2a6ada165cf
--- /dev/null
+++ b/dev-libs/mpc/mpc-0.8.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpc/mpc-0.8.1.ebuild,v 1.1 2010/01/19 05:19:29 dirtyepic Exp $
+
+EAPI=0
+
+DESCRIPTION="A library for multiprecision complex arithmetic with exact rounding."
+HOMEPAGE="http://mpc.multiprecision.org/"
+SRC_URI="http://www.multiprecision.org/mpc/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-libs/gmp-4.2.3
+ >=dev-libs/mpfr-2.3.1"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc "${S}"/{ChangeLog,NEWS,README,TODO}
+}