summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-02 10:38:42 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-02 10:38:42 +0000
commitbd5293d067263f1117b796ed692ff8e50104e068 (patch)
tree42cf4b690f2cf4d2da832a61b2100aca6d37ec97 /dev-libs/maloc/maloc-1.5.ebuild
parentsci-mathematics/gimps: Fix checksums again, #414073 (diff)
downloadhistorical-bd5293d067263f1117b796ed692ff8e50104e068.tar.gz
historical-bd5293d067263f1117b796ed692ff8e50104e068.tar.bz2
historical-bd5293d067263f1117b796ed692ff8e50104e068.zip
dev-libs/maloc: Move to autotools-utils.eclass
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/maloc/maloc-1.5.ebuild')
-rw-r--r--dev-libs/maloc/maloc-1.5.ebuild46
1 files changed, 22 insertions, 24 deletions
diff --git a/dev-libs/maloc/maloc-1.5.ebuild b/dev-libs/maloc/maloc-1.5.ebuild
index 5ff459988563..5cc69b362228 100644
--- a/dev-libs/maloc/maloc-1.5.ebuild
+++ b/dev-libs/maloc/maloc-1.5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-1.5.ebuild,v 1.2 2011/04/16 06:56:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-1.5.ebuild,v 1.3 2012/05/02 10:38:42 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
DESCRIPTION="Minimal Abstraction Layer for Object-oriented C/C++ programs"
HOMEPAGE="http://www.fetk.org/codes/maloc/index.html"
@@ -25,32 +27,28 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/1.4-mpi.patch \
- "${FILESDIR}"/1.4-asneeded.patch \
- "${FILESDIR}"/1.4-doc.patch
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/1.4-mpi.patch
+ "${FILESDIR}"/1.4-asneeded.patch
+ "${FILESDIR}"/1.4-doc.patch
+ )
src_configure() {
- local myconf
+ local myeconfargs
use mpi && export CC="mpicc"
- use doc || myconf="${myconf} --with-doxygen= --with-dot="
-
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable mpi) \
- $(use_enable static-libs static) \
- --disable-triplet \
- --enable-shared \
- ${myconf}
+ use doc || myeconfargs+=( --with-doxygen= --with-dot= )
+
+ myeconfargs+=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable mpi)
+ --disable-triplet
+ )
+ autotools-utils_src_configure
}
src_install() {
- # install libs and headers
- emake DESTDIR="${D}" install || die "make install failed"
+ autotools-utils_src_install
# install doc
- dohtml doc/index.html || die "failed to install html docs"
+ dohtml doc/index.html
}