summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-31 02:33:45 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-31 02:33:45 +0000
commitcc30ed22b6f86a46e1e0c715df8b29aae62eddb9 (patch)
tree102943c2c3a84c63473981d5bb6ae6798fd99ac2 /dev-libs/libxml2
parentmore GNOME 2.2 RC2 mask (diff)
downloadhistorical-cc30ed22b6f86a46e1e0c715df8b29aae62eddb9.tar.gz
historical-cc30ed22b6f86a46e1e0c715df8b29aae62eddb9.tar.bz2
historical-cc30ed22b6f86a46e1e0c715df8b29aae62eddb9.zip
GNOME 2.2 RC2 commit
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.5.11
-rw-r--r--dev-libs/libxml2/libxml2-2.5.1.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 59969b7c4d4e..435bade7d194 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.23 2003/01/21 14:08:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.24 2003/01/31 02:33:45 foser Exp $
+
+*libxml2-2.5.1 (30 Jan 2003)
+
+ 30 Jan 2003; foser <foser@gentoo.org> libxml2-2.5.1.ebuild :
+ GNOME 2.2 RC2 commit
*libxml2-2.4.30 (07 Jan 2003)
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.5.1 b/dev-libs/libxml2/files/digest-libxml2-2.5.1
new file mode 100644
index 000000000000..0651c1a5215f
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.5.1
@@ -0,0 +1 @@
+MD5 60c2149d466d46e3662339d940a8cd24 libxml2-2.5.1.tar.bz2 2199806
diff --git a/dev-libs/libxml2/libxml2-2.5.1.ebuild b/dev-libs/libxml2/libxml2-2.5.1.ebuild
new file mode 100644
index 000000000000..3da982534e1f
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.5.1.ebuild,v 1.1 2003/01/31 02:33:45 foser Exp $
+
+inherit eutils libtool gnome.org
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}