summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-08-27 01:07:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-08-27 01:07:33 +0000
commit69ee7ac9fb9b9506a3d94107f733a6397db77660 (patch)
tree94e87c0fd8f20c7575d4f6f33c61bc82a1bc076f /dev-libs/libusb/libusb-1.0.2.ebuild
parentVersion bump. Change the pvmetadatacopies default back to 1 to cut down on pv... (diff)
downloadhistorical-69ee7ac9fb9b9506a3d94107f733a6397db77660.tar.gz
historical-69ee7ac9fb9b9506a3d94107f733a6397db77660.tar.bz2
historical-69ee7ac9fb9b9506a3d94107f733a6397db77660.zip
Bug #282156: version bump, has endian fixes.
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libusb/libusb-1.0.2.ebuild')
-rw-r--r--dev-libs/libusb/libusb-1.0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libusb/libusb-1.0.2.ebuild b/dev-libs/libusb/libusb-1.0.2.ebuild
new file mode 100644
index 000000000000..3223169f8146
--- /dev/null
+++ b/dev-libs/libusb/libusb-1.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-1.0.2.ebuild,v 1.1 2009/08/27 01:07:33 robbat2 Exp $
+
+EAPI="2"
+
+DESCRIPTION="Userspace access to USB devices"
+HOMEPAGE="http://libusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libusb/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd"
+IUSE="debug doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug debug-log)
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd doc
+ emake docs || die "making docs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS PORTING README THANKS TODO
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+
+ dohtml doc/html/*
+ fi
+}