summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-03-18 12:18:02 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-03-18 12:18:02 +0000
commit36317c2e8dd0871816488ab3f365375bc9bac15a (patch)
tree3dee3f20ff53046896783ff53be822860022aee5 /dev-libs/libusb/libusb-0.1.10a.ebuild
parentnew snapshot version (diff)
downloadhistorical-36317c2e8dd0871816488ab3f365375bc9bac15a.tar.gz
historical-36317c2e8dd0871816488ab3f365375bc9bac15a.tar.bz2
historical-36317c2e8dd0871816488ab3f365375bc9bac15a.zip
version bump (#81727). removing amd64 -fPIC hack.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-libs/libusb/libusb-0.1.10a.ebuild')
-rw-r--r--dev-libs/libusb/libusb-0.1.10a.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libusb/libusb-0.1.10a.ebuild b/dev-libs/libusb/libusb-0.1.10a.ebuild
new file mode 100644
index 000000000000..82a7f5c07a0a
--- /dev/null
+++ b/dev-libs/libusb/libusb-0.1.10a.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.10a.ebuild,v 1.1 2005/03/18 12:18:02 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="Userspace access to USB devices"
+HOMEPAGE="http://libusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libusb/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND="sys-devel/libtool
+ doc? ( app-text/openjade
+ ~app-text/docbook-sgml-dtd-4.2 )"
+
+src_unpack(){
+ unpack ${A}
+
+ if use ppc || use ppc-macos ; then
+ aclocal || die
+ autoconf || die
+ automake --add-missing || die
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ # keep this otherwise libraries will not have .so extensions
+ use ppc-macos \
+ && glibtoolize --force \
+ || libtoolize --force
+
+ use doc \
+ && myconf="--enable-build-docs" \
+ || myconf="--disable-build-docs"
+
+ use debug \
+ && myconf="${myconf} --enable-debug=all" \
+ || myconf="${myconf} --disable-debug"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS NEWS README || die
+ if use doc; then
+ dohtml doc/html/*.html || die
+ fi
+}