summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-03-07 23:22:44 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-03-07 23:22:44 +0000
commitc7336a32ffb4373c272fe54219ed6c03e3b34f35 (patch)
treed2697436400e550d2845dcb2870461f114ff873e /dev-libs/libpcre/libpcre-6.6.ebuild
parentAdd support for modular X #121067. (diff)
downloadhistorical-c7336a32ffb4373c272fe54219ed6c03e3b34f35.tar.gz
historical-c7336a32ffb4373c272fe54219ed6c03e3b34f35.tar.bz2
historical-c7336a32ffb4373c272fe54219ed6c03e3b34f35.zip
Version bump.
Package-Manager: portage-2.0.54
Diffstat (limited to 'dev-libs/libpcre/libpcre-6.6.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-6.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libpcre/libpcre-6.6.ebuild b/dev-libs/libpcre/libpcre-6.6.ebuild
new file mode 100644
index 000000000000..77e4c71a368c
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-6.6.ebuild,v 1.1 2006/03/07 23:22:44 carlo Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+S=${WORKDIR}/pcre-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/pcre-6.3-uclibc-tuple.patch
+ epatch "${FILESDIR}"/pcre-6.4-link.patch
+
+ # TODO: Fix this. Use -fPIC just for the shared objects.
+ # position-independent code must used for all shared objects.
+ ewarn "TODO: Fix this bad -fPIC handling"
+ append-flags -fPIC
+
+ elibtoolize
+}
+
+src_compile() {
+ # How about the following flags?
+ # --enable-unicode-properties enable Unicode properties support
+ # --disable-stack-for-recursion disable use of stack recursion when matching
+ econf --enable-utf8 || die
+ emake all libpcrecpp.la || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS INSTALL NON-UNIX-USE
+ dodoc doc/*.txt doc/Tech.Notes
+ use doc && dohtml doc/html/*
+}