summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2007-11-02 15:51:14 +0000
committerJulien Allanos <dju@gentoo.org>2007-11-02 15:51:14 +0000
commit3fcb69725370d1349b6346d5eae6db95b829a4c1 (patch)
treefe0113b9911d993db0cfdba6b3df9e7ac38d8133 /dev-libs/clearsilver/clearsilver-0.10.5.ebuild
parentFix DEPEND (diff)
downloadhistorical-3fcb69725370d1349b6346d5eae6db95b829a4c1.tar.gz
historical-3fcb69725370d1349b6346d5eae6db95b829a4c1.tar.bz2
historical-3fcb69725370d1349b6346d5eae6db95b829a4c1.zip
Version bump to 0.10.5, fixing bug #191601. Added user patch to fix bug #196422.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'dev-libs/clearsilver/clearsilver-0.10.5.ebuild')
-rw-r--r--dev-libs/clearsilver/clearsilver-0.10.5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/clearsilver/clearsilver-0.10.5.ebuild b/dev-libs/clearsilver/clearsilver-0.10.5.ebuild
new file mode 100644
index 000000000000..05afa0bef437
--- /dev/null
+++ b/dev-libs/clearsilver/clearsilver-0.10.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/clearsilver/clearsilver-0.10.5.ebuild,v 1.1 2007/11/02 15:51:13 dju Exp $
+
+# Please note: apache, java, mono and ruby support disabled for now.
+# Fill a bug if you need it.
+#
+# dju@gentoo.org, 4th July 2005
+
+inherit eutils perl-app multilib autotools
+
+DESCRIPTION="Clearsilver is a fast, powerful, and language-neutral HTML template system."
+HOMEPAGE="http://www.clearsilver.net/"
+SRC_URI="http://www.clearsilver.net/downloads/${P}.tar.gz"
+
+LICENSE="CS-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="perl python zlib"
+
+DEPEND="python? ( dev-lang/python )
+ perl? ( dev-lang/perl )
+ zlib? ( sys-libs/zlib )"
+
+DOCS="README INSTALL"
+
+if use python ; then
+ DOCS="${DOCS} README.python"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use zlib && epatch "${FILESDIR}"/${P}-libz.patch
+
+ epatch "${FILESDIR}"/${P}-libdir.patch
+ sed -i -e "s:GENTOO_LIBDIR:$(get_libdir):" configure.in
+ eautoreconf || die "eautoreconf failed"
+
+ # Fix for Gentoo/Freebsd
+ [[ "${ARCH}" == FreeBSD ]] && touch ${S}/features.h ${S}/cgi/features.h
+}
+
+src_compile() {
+ econf \
+ $(use_enable perl) \
+ $(use_with perl perl /usr/bin/perl) \
+ $(use_enable python) \
+ $(use_with python python /usr/bin/python) \
+ $(use_enable zlib compression) \
+ "--disable-apache" \
+ "--disable-ruby" \
+ "--disable-java" \
+ "--disable-csharp" \
+ || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ cd ${S}
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ${DOCS} || die "dodoc failed"
+
+ if use perl ; then
+ fixlocalpod || die "fixlocalpod failed"
+ fi
+}