summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-11 18:03:34 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-11 18:03:34 +0000
commitf8f43359c7b9eacae0bb6544b6a2cb328547f5e1 (patch)
tree2cdadf1090ee0f672c6636cb1b3dca8faf7503f1 /dev-libs/boost
parent(no commit message) (diff)
downloadhistorical-f8f43359c7b9eacae0bb6544b6a2cb328547f5e1.tar.gz
historical-f8f43359c7b9eacae0bb6544b6a2cb328547f5e1.tar.bz2
historical-f8f43359c7b9eacae0bb6544b6a2cb328547f5e1.zip
fixed up ${arch} for amd64
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/Manifest10
-rw-r--r--dev-libs/boost/boost-1.32.0.ebuild11
3 files changed, 18 insertions, 8 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index a8ba92b1e7ff..371e30321e11 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.24 2004/12/11 17:31:52 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.25 2004/12/11 18:03:34 morfic Exp $
+
+ 11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
+ fixed up ${arch} to cover amd64 as not being recognized
11 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
Added ${arch} to bjam path
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 0015072c2b91..713d0e105e85 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -2,10 +2,10 @@
Hash: SHA1
MD5 c0e0b430578e177a32295ce8f365302d boost-1.31.0.ebuild 3967
-MD5 abe0fbb744a404dc651b9751712dabe8 boost-1.32.0.ebuild 2200
+MD5 1cd8a2e856dcfc4cdc0eca0c663eabe7 boost-1.32.0.ebuild 2299
MD5 7a5736de479368e026895776885a1f4c boost-1.29.0.ebuild 1428
MD5 c38336b27cb2a10759ade6f16799d051 boost-1.30.0.ebuild 2977
-MD5 baabece31690a303706b234341dee8b3 ChangeLog 3997
+MD5 60ab1e8e03d8b095cae3bac4490fddf7 ChangeLog 4126
MD5 19f97285acdda370e331ee909e26df4c metadata.xml 340
MD5 6fd34399d93efc1de1221666ed6d37d1 boost-1.30.2.ebuild 2964
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
@@ -16,7 +16,7 @@ MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBuy74UpKYMelfdYERAmuHAJ96QhoKkYWrZTrGtreyIpKRD38apQCdFcOU
-wC0MFm4TquAMCytois62hX4=
-=ZhPb
+iD4DBQFBuzZmUpKYMelfdYERAh8IAJiubbUq32Lvg6/md82jO6U29EM2AJ932SOv
+4a/p6aivf2zyFKe6NsX8xQ==
+=o204
-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.32.0.ebuild b/dev-libs/boost/boost-1.32.0.ebuild
index 0844c81e47d3..6bdb628782a0 100644
--- a/dev-libs/boost/boost-1.32.0.ebuild
+++ b/dev-libs/boost/boost-1.32.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.2 2004/12/11 17:31:52 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.3 2004/12/11 18:03:34 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
@@ -20,6 +20,13 @@ KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
src_compile() {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
+ local arch
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
# Build bjam, a jam variant, which is used instead of make
cd ${S}/tools/build/jam_src
@@ -40,7 +47,7 @@ src_compile() {
src_install () {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
- ./tools/build/jam_src/bin.linux${arch}/bjam \
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \