summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:07:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:07:18 +0000
commitfeeaa21894d5d189b0e360be5ea3d1b8ffd738a7 (patch)
tree6afacc05d0c699937aaff3b85458cd400e16922c /dev-libs/atk
parentrepoman'd directory (diff)
downloadhistorical-feeaa21894d5d189b0e360be5ea3d1b8ffd738a7.tar.gz
historical-feeaa21894d5d189b0e360be5ea3d1b8ffd738a7.tar.bz2
historical-feeaa21894d5d189b0e360be5ea3d1b8ffd738a7.zip
repoman'd
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/atk-1.0.1-r3.ebuild29
-rw-r--r--dev-libs/atk/atk-1.0.2.ebuild28
2 files changed, 23 insertions, 34 deletions
diff --git a/dev-libs/atk/atk-1.0.1-r3.ebuild b/dev-libs/atk/atk-1.0.1-r3.ebuild
index 3cb52b15be94..c3b55edba882 100644
--- a/dev-libs/atk/atk-1.0.1-r3.ebuild
+++ b/dev-libs/atk/atk-1.0.1-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.1-r3.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.1-r3.ebuild,v 1.3 2002/08/01 16:07:17 seemant Exp $
+
+inherit libtool
# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
DEBUG="yes"
@@ -10,12 +12,14 @@ CFLAGS="${CFLAGS} -g"
CXXFLAGS="${CXXFLAGS} -g"
-SLOT="1"
S=${WORKDIR}/${P}
DESCRIPTION="Gnome Accessibility Toolkit"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+SLOT="1"
LICENSE="LGPL-2.1"
+KEYWORDS="X86"
RDEPEND=">=dev-libs/glib-2.0.1"
@@ -24,17 +28,13 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- libtoolize --copy --force
+ elibtoolize
local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --enable-debug || die
+ econf ${myconf} --enable-debug || die
## Since glib fails with debug, we debug here too
@@ -42,12 +42,7 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
+ einstall || die
dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
}
-
diff --git a/dev-libs/atk/atk-1.0.2.ebuild b/dev-libs/atk/atk-1.0.2.ebuild
index 400f44e5b477..0571b76b2656 100644
--- a/dev-libs/atk/atk-1.0.2.ebuild
+++ b/dev-libs/atk/atk-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.2.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atk/atk-1.0.2.ebuild,v 1.3 2002/08/01 16:07:17 seemant Exp $
# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
DEBUG="yes"
@@ -10,12 +10,14 @@ CFLAGS="${CFLAGS} -g"
CXXFLAGS="${CXXFLAGS} -g"
-SLOT="1"
S=${WORKDIR}/${P}
DESCRIPTION="Gnome Accessibility Toolkit"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+SLOT="1"
LICENSE="LGPL-2.1"
+KEYWORDS="x86"
RDEPEND=">=dev-libs/glib-2.0.3"
@@ -27,15 +29,13 @@ src_compile() {
# since no other of gtk pango and glib use this, remove it. its not recommended either
# libtoolize --copy --force
local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --enable-debug || die
+ econf \
+ --enable-debug \
+ ${myconf} || die
## Since glib fails with debug, we debug here too
@@ -43,12 +43,6 @@ src_compile() {
}
src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
+ einstall || die
dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS
}
-