summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-09-15 20:08:48 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-09-15 20:08:48 +0000
commit94e8733038b761670c1494f9d541ebc648153ce3 (patch)
tree91f4137e250a918cc2a76edda554607348ddd497 /dev-lang
parentadded try syntax (diff)
downloadhistorical-94e8733038b761670c1494f9d541ebc648153ce3.tar.gz
historical-94e8733038b761670c1494f9d541ebc648153ce3.tar.bz2
historical-94e8733038b761670c1494f9d541ebc648153ce3.zip
added try syntax
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nasm/nasm-0.98-r1.ebuild8
-rw-r--r--dev-lang/php-4/php-4.0.0-r1.ebuild6
-rw-r--r--dev-lang/php-4/php-4.0.1-r1.ebuild6
-rw-r--r--dev-lang/php-4/php-4.0.1_p2-r1.ebuild6
-rw-r--r--dev-lang/python/python-1.5.2-r1.ebuild8
-rw-r--r--dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild14
-rw-r--r--dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild14
7 files changed, 31 insertions, 31 deletions
diff --git a/dev-lang/nasm/nasm-0.98-r1.ebuild b/dev-lang/nasm/nasm-0.98-r1.ebuild
index 330b13d5d6aa..5f0f53f94db1 100644
--- a/dev-lang/nasm/nasm-0.98-r1.ebuild
+++ b/dev-lang/nasm/nasm-0.98-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r1.ebuild,v 1.3 2000/09/15 20:08:47 drobbins Exp $
P=nasm-0.98
A=${P}.tar.bz2
@@ -11,10 +11,10 @@ SRC_URI="ftp://ftp.kernel.org/pub/software/devel/nasm/source/nasm-0.98.tar.bz2"
HOMEPAGE="http://nasm.sourceforge.net/"
src_compile() {
- ./configure --prefix=/usr
- make
+ try ./configure --prefix=/usr
+ try make
cd doc
- make
+ try make
}
src_install() {
diff --git a/dev-lang/php-4/php-4.0.0-r1.ebuild b/dev-lang/php-4/php-4.0.0-r1.ebuild
index 794419ed0819..815946bfbf5b 100644
--- a/dev-lang/php-4/php-4.0.0-r1.ebuild
+++ b/dev-lang/php-4/php-4.0.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.0-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.0-r1.ebuild,v 1.3 2000/09/15 20:08:47 drobbins Exp $
P=php-4.0.0
A="php-4.0.0.tar.gz number4.tar.gz"
@@ -18,14 +18,14 @@ src_compile() {
# export CPPFLAGS=$FLAGS
# export CXXFLAGS=$FLAGS
export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- ./configure --with-mysql=yes --enable-safe-mode \
+ try ./configure --with-mysql=yes --enable-safe-mode \
--enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
--with-readline --with-gettext --enable-calendar --with-ldap\
--with-gd --with-ttf --with-jpeg-dir=/usr/lib \
--with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
--with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
--enable-versioning --enable-inline-optimization --enable-trans-sid --enable-track-vars
- make
+ try make
}
src_unpack() {
diff --git a/dev-lang/php-4/php-4.0.1-r1.ebuild b/dev-lang/php-4/php-4.0.1-r1.ebuild
index 399d90d3b34f..6e5bd075ebb7 100644
--- a/dev-lang/php-4/php-4.0.1-r1.ebuild
+++ b/dev-lang/php-4/php-4.0.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1-r1.ebuild,v 1.3 2000/09/15 20:08:47 drobbins Exp $
P=php-4.0.1
A="php-4.0.1.tar.gz number4.tar.gz"
@@ -18,14 +18,14 @@ src_compile() {
# export CPPFLAGS=$FLAGS
# export CXXFLAGS=$FLAGS
export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- ./configure --with-mysql=yes --enable-safe-mode \
+ try ./configure --with-mysql=yes --enable-safe-mode \
--enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
--with-readline --with-gettext --enable-calendar --with-ldap\
--with-gd --with-ttf --with-jpeg-dir=/usr/lib \
--with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
--with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
--enable-versioning --enable-inline-optimization --enable-trans-sid
- make
+ try make
}
src_unpack() {
diff --git a/dev-lang/php-4/php-4.0.1_p2-r1.ebuild b/dev-lang/php-4/php-4.0.1_p2-r1.ebuild
index 9900e471c6b7..df6acc6d2ca3 100644
--- a/dev-lang/php-4/php-4.0.1_p2-r1.ebuild
+++ b/dev-lang/php-4/php-4.0.1_p2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1_p2-r1.ebuild,v 1.1 2000/08/16 15:08:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1_p2-r1.ebuild,v 1.2 2000/09/15 20:08:47 drobbins Exp $
P=php-4.0.1pl2
A="${P}.tar.gz number4.tar.gz"
@@ -14,14 +14,14 @@ HOMEPAGE="http://www.php.net/"
src_compile() {
export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- ./configure --with-mysql=yes --enable-safe-mode \
+ try ./configure --with-mysql=yes --enable-safe-mode \
--enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
--with-readline --with-gettext --enable-calendar --with-ldap\
--with-gd --with-ttf --with-t1lib --with-jpeg-dir=/usr/lib \
--with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
--with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
--enable-versioning --enable-inline-optimization --enable-trans-sid --enable-track-vars
- make
+ try make
}
src_unpack() {
diff --git a/dev-lang/python/python-1.5.2-r1.ebuild b/dev-lang/python/python-1.5.2-r1.ebuild
index 634b957b0735..1e09c164eea8 100644
--- a/dev-lang/python/python-1.5.2-r1.ebuild
+++ b/dev-lang/python/python-1.5.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-1.5.2-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-1.5.2-r1.ebuild,v 1.3 2000/09/15 20:08:47 drobbins Exp $
P=python-1.5.2
A=py152.tgz
@@ -11,10 +11,10 @@ SRC_URI="http://www.python.org/ftp/python/src/py152.tgz"
HOMEPAGE="http://www.python.org/"
src_compile() {
- ./configure --prefix=/usr --with-threads
+ try ./configure --prefix=/usr --with-threads
cp Makefile Makefile.orig
sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- make
+ try make
}
src_unpack() {
@@ -33,7 +33,7 @@ Setup.in > Setup
src_install() {
dodir /usr
- make install prefix=${D}/usr
+ try make install prefix=${D}/usr
prepman
strip ${D}/usr/bin/python
diff --git a/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild b/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild
index ceea3d470bcd..99bd2d3d4153 100644
--- a/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild
+++ b/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild,v 1.3 2000/09/15 20:08:48 drobbins Exp $
#
P=tcl-tk-8.0.5
@@ -35,18 +35,18 @@ src_unpack() {
src_compile() {
cd ${S1}/unix
- ./configure --host=${CHOST} --prefix=/usr --enable-shared
- make
+ try ./configure --host=${CHOST} --prefix=/usr --enable-shared
+ try make
cd ${S2}/unix
- ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-shared
- make
+ try ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-shared
+ try make
}
src_install() {
cd ${S1}/unix
- make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} install
cd ${S2}/unix
- make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} install
strip ${D}/usr/bin/*
# ln -sf wish8.1 ${D}/usr/bin/wish
# ln -sf tclsh8.1 ${D}/usr/bin/tclsh
diff --git a/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild b/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild
index b23bc6a75f3a..06ab17b2502e 100644
--- a/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild
+++ b/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild,v 1.2 2000/08/16 04:37:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild,v 1.3 2000/09/15 20:08:48 drobbins Exp $
P=tcl-tk-8.1.1
@@ -34,18 +34,18 @@ src_unpack() {
src_compile() {
cd ${S1}/unix
- ./configure --host=${CHOST} --prefix=/usr --enable-threads
- make
+ try ./configure --host=${CHOST} --prefix=/usr --enable-threads
+ try make
cd ${S2}/unix
- ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-threads
- make
+ try ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-threads
+ try make
}
src_install() {
cd ${S1}/unix
- make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} install
cd ${S2}/unix
- make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} install
strip ${D}/usr/bin/*
ln -sf wish8.1 ${D}/usr/bin/wish
ln -sf tclsh8.1 ${D}/usr/bin/tclsh