summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2007-04-22 01:08:13 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2007-04-22 01:08:13 +0000
commita438bb160d2b5e3ac1d05d8306e205c2d6da99a5 (patch)
tree232629f709511188b9f604d74a896c434a5ee576 /dev-lang/yasm/yasm-0.6.0.ebuild
parentManual Manifest commit. (diff)
downloadhistorical-a438bb160d2b5e3ac1d05d8306e205c2d6da99a5.tar.gz
historical-a438bb160d2b5e3ac1d05d8306e205c2d6da99a5.tar.bz2
historical-a438bb160d2b5e3ac1d05d8306e205c2d6da99a5.zip
Remove macho object format tests in dev-lang/yasm-0.6.0 until fixed upstream. See bug #174020.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'dev-lang/yasm/yasm-0.6.0.ebuild')
-rw-r--r--dev-lang/yasm/yasm-0.6.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/yasm/yasm-0.6.0.ebuild b/dev-lang/yasm/yasm-0.6.0.ebuild
index a171f19b4dd7..146c8a148740 100644
--- a/dev-lang/yasm/yasm-0.6.0.ebuild
+++ b/dev-lang/yasm/yasm-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.6.0.ebuild,v 1.1 2007/03/20 01:10:46 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.6.0.ebuild,v 1.2 2007/04/22 01:08:13 kugelfang Exp $
inherit versionator
@@ -16,6 +16,16 @@ IUSE="nls"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Remove macho tests (gas{32,64},nasm{32,64}) until fixed upstream.
+ # Necessary to pass test phase on at least amd64 with gcc-4.1.2.
+ sed -i \
+ -e '/modules\/objfmts\/macho\/tests\/.*\/.*macho.*_test.sh/d' \
+ Makefile.in
+}
+
src_compile() {
econf $(use_enable nls) || die "econf failed"
emake || die "emake failed"