summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 22:27:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-06 22:27:54 +0000
commit671ee61508947ebca9ecf7095ef0d36d5cc058a6 (patch)
treebfbd7af201da15d384c92859ef509f158d437e66 /dev-lang/squeak
parentrepoman: trim trailing whitespace (diff)
downloadhistorical-671ee61508947ebca9ecf7095ef0d36d5cc058a6.tar.gz
historical-671ee61508947ebca9ecf7095ef0d36d5cc058a6.tar.bz2
historical-671ee61508947ebca9ecf7095ef0d36d5cc058a6.zip
repoman: trim trailing whitespace
Diffstat (limited to 'dev-lang/squeak')
-rw-r--r--dev-lang/squeak/Manifest4
-rw-r--r--dev-lang/squeak/squeak-3.2.5.ebuild36
-rw-r--r--dev-lang/squeak/squeak-3.4.1.ebuild36
3 files changed, 38 insertions, 38 deletions
diff --git a/dev-lang/squeak/Manifest b/dev-lang/squeak/Manifest
index dc24f2866a64..0bcef493a546 100644
--- a/dev-lang/squeak/Manifest
+++ b/dev-lang/squeak/Manifest
@@ -1,5 +1,5 @@
MD5 0f3f5efa09089b39c09eea1d4d7a125b ChangeLog 544
-MD5 c53bbaba9bcac50e70877300900630b7 squeak-3.2.5.ebuild 2960
-MD5 814cd5ddbbbeb941d7b024dd5228faca squeak-3.4.1.ebuild 3024
+MD5 f558da018cd99c1230db0c9fe96c8672 squeak-3.2.5.ebuild 2925
+MD5 c5ee64830a6abb8992d522b313a0ab02 squeak-3.4.1.ebuild 2988
MD5 95975b038cad92087afe83055e6b2137 files/digest-squeak-3.2.5 69
MD5 e15651f69bf3b5c02f40bcffceefb53c files/digest-squeak-3.4.1 69
diff --git a/dev-lang/squeak/squeak-3.2.5.ebuild b/dev-lang/squeak/squeak-3.2.5.ebuild
index 6e1445d0bdcb..d7f239ec8c1e 100644
--- a/dev-lang/squeak/squeak-3.2.5.ebuild
+++ b/dev-lang/squeak/squeak-3.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.2.5.ebuild,v 1.2 2003/02/13 10:29:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.2.5.ebuild,v 1.3 2003/09/06 22:27:51 msterret Exp $
DESCRIPTION="Highly-portable Smalltalk-80 implementation"
HOMEPAGE="http://www.squeak.org/"
@@ -19,13 +19,13 @@ RDEPEND="=dev-lang/squeak-vm-3.2*
S="${WORKDIR}/Squeak-3.2-5"
-src_compile() {
+src_compile() {
local myconf=""
-
+
use X || myconf="--without-x"
use oss && myconf="${myconf} --with-audio=oss"
use mmx && myconf="${myconf} --enable-mpg-mmx"
-
+
cd ${S}
mkdir build
cd build
@@ -47,9 +47,9 @@ src_compile() {
emake || die
}
-src_install() {
- cd ${S}/build
-
+src_install() {
+ cd ${S}/build
+
make DESTDIR=${D} ROOT=${D} install || die
exeinto /usr/bin
@@ -58,9 +58,9 @@ src_install() {
### the rest is all for the plugin
cd nps
-
+
# plugin sample, must be served to work, file:// doesnt work.
-
+
insinto /usr/share/doc/squeak-3.2.5
doins test/plugintest.html
doins test/plugintest.sts
@@ -69,35 +69,35 @@ src_install() {
SQ_DIR=/usr/lib/squeak
VM_VERSION=3.2-5
- NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
npsqueakrun.in > npsqueakrun.in.2
sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
npsqueakregister.in > npsqueakregister
sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
- exeinto /usr/lib/squeak
- doexe npsqueakregister
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
exeinto /usr/lib/squeak/3.2-5
doexe npsqueakrun
# install in browsers (no opera use flags?)
- dodir /opt/netscape/plugins
- dosym /usr/lib/squeak/3.2-5/npsqueak.so /opt/netscape/plugins
-
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/3.2-5/npsqueak.so /opt/netscape/plugins
+
if [ "`use mozilla`" ] ; then
dodir /usr/lib/mozilla/plugins
dosym /opt/netscape/plugins/npsqueak.so \
/usr/lib/mozilla/plugins/npsqueak.so
fi
-
+
# maybe we should install the image here..
-
+
# dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/3.2-5/SqueakV3.sources
# doins npsqueak.image
- # doins npsqueak.changes
+ # doins npsqueak.changes
}
pkg_postinst() {
diff --git a/dev-lang/squeak/squeak-3.4.1.ebuild b/dev-lang/squeak/squeak-3.4.1.ebuild
index 6349264c3afe..687998cbd506 100644
--- a/dev-lang/squeak/squeak-3.4.1.ebuild
+++ b/dev-lang/squeak/squeak-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1.ebuild,v 1.1 2003/05/21 11:53:43 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1.ebuild,v 1.2 2003/09/06 22:27:51 msterret Exp $
#Simply change these numbers for different versions
MV=3.4
@@ -24,13 +24,13 @@ RDEPEND="dev-lang/squeak-vm
S="${WORKDIR}/Squeak-${NV}"
-src_compile() {
+src_compile() {
local myconf=""
-
+
use X || myconf="--without-x"
use oss && myconf="${myconf} --with-audio=oss"
use mmx && myconf="${myconf} --enable-mpg-mmx"
-
+
cd ${S}
mkdir build
cd build
@@ -52,9 +52,9 @@ src_compile() {
emake || die
}
-src_install() {
- cd ${S}/build
-
+src_install() {
+ cd ${S}/build
+
make DESTDIR=${D} ROOT=${D} install || die
exeinto /usr/bin
@@ -63,9 +63,9 @@ src_install() {
### the rest is all for the plugin
cd nps
-
+
# plugin sample, must be served to work, file:// doesnt work.
-
+
insinto /usr/share/doc/squeak-${FV}
doins test/plugintest.html
doins test/plugintest.sts
@@ -74,35 +74,35 @@ src_install() {
SQ_DIR=/usr/lib/squeak
VM_VERSION=${NV}
- NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
npsqueakrun.in > npsqueakrun.in.2
sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
npsqueakregister.in > npsqueakregister
sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
- exeinto /usr/lib/squeak
- doexe npsqueakregister
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
exeinto /usr/lib/squeak/${NV}
doexe npsqueakrun
# install in browsers (no opera use flags?)
- dodir /opt/netscape/plugins
- dosym /usr/lib/squeak/${NV}/npsqueak.so /opt/netscape/plugins
-
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/${NV}/npsqueak.so /opt/netscape/plugins
+
if [ "`use mozilla`" ] ; then
dodir /usr/lib/mozilla/plugins
dosym /opt/netscape/plugins/npsqueak.so \
/usr/lib/mozilla/plugins/npsqueak.so
fi
-
+
# maybe we should install the image here..
-
+
# dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/${NV}/SqueakV3.sources
# doins npsqueak.image
- # doins npsqueak.changes
+ # doins npsqueak.changes
}
pkg_postinst() {