summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-01 00:33:56 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-01 00:33:56 +0000
commitff6f6871fb892e19b0bb0d8544117de88c0f89f0 (patch)
tree67a40a1cdf4167a3f93c76b499b82e886e72cd4d /dev-lang/smlnj/smlnj-110.43.ebuild
parentadded metadata.xml and cleanup whitespace (diff)
downloadhistorical-ff6f6871fb892e19b0bb0d8544117de88c0f89f0.tar.gz
historical-ff6f6871fb892e19b0bb0d8544117de88c0f89f0.tar.bz2
historical-ff6f6871fb892e19b0bb0d8544117de88c0f89f0.zip
moved 110.42 into stable, added 110.43 (new version)
Diffstat (limited to 'dev-lang/smlnj/smlnj-110.43.ebuild')
-rw-r--r--dev-lang/smlnj/smlnj-110.43.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-lang/smlnj/smlnj-110.43.ebuild b/dev-lang/smlnj/smlnj-110.43.ebuild
new file mode 100644
index 000000000000..dbdd74ebb168
--- /dev/null
+++ b/dev-lang/smlnj/smlnj-110.43.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.43.ebuild,v 1.1 2003/10/01 00:33:48 george Exp $
+
+IUSE=""
+
+DESCRIPTION="Standard ML of New Jersey compiler and libraries"
+SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/config.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/runtime.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/boot.x86-unix.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-lex.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-yacc.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/ml-burg.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/smlnj-lib.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/cml.tgz
+ ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/eXene.tgz"
+
+HOMEPAGE="http://cm.bell-labs.com/cm/cs/what/smlnj/"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+SLOT="0"
+DEPEND="virtual/glibc"
+
+SMLNJ_DEST="/usr/share/smlnj"
+SMLNJ_TARGETS="./config/targets"
+
+GEN_POSIX_NAMES_PATCH="15i\n#\n.\nj\nw\nq"
+
+ARCH_BOOT="sml.boot.x86-unix"
+
+src_unpack() {
+ unpack ${A}
+
+ dirs=`ls ${WORKDIR}`
+ mkdir ${WORKDIR}/src
+
+ for i in $dirs; do
+ if test "$i" != "config" -a "$i" != ${ARCH_BOOT}; then
+ mv ${WORKDIR}/${i} ${WORKDIR}/src
+ fi
+ done
+
+ printf ${GEN_POSIX_NAMES_PATCH} | ed -s ${WORKDIR}/src/runtime/config/gen-posix-names.sh
+}
+
+src_compile() {
+ if test "${SMLNJ_HOME}" != ""; then
+ SMLNJ_HOME=""
+ fi
+
+ cd ${WORKDIR}
+
+ echo "request ml-burg" >> $SMLNJ_TARGETS
+ echo "request cml" >> $SMLNJ_TARGETS
+ echo "request cml-lib" >> $SMLNJ_TARGETS
+ echo "request eXene" >> $SMLNJ_TARGETS
+
+ ./config/install.sh || die
+}
+
+src_install () {
+
+ dodir ${SMLNJ_DEST}
+
+ cp -r ${WORKDIR}/{bin,lib} ${D}${SMLNJ_DEST} || die
+
+ dodir /etc/env.d
+ echo -e SMLNJ_HOME=${SMLNJ_DEST} > ${D}/etc/env.d/10smlnj
+
+ #need to provide symlinks into /usr/bin
+ dodir /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-build /usr/bin/
+ dosym ${SMLNJ_DEST}/bin/ml-burg /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-lex /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-makedepend /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-yacc /usr/bin
+ dosym ${SMLNJ_DEST}/bin/sml /usr/bin
+
+}