summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-29 16:25:46 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-29 16:25:46 +0000
commit6f7e40f158ac23f170ea80ab257c1dc30751fc49 (patch)
tree0bc7781b495099bef1b8995ea1f59e67d2f28d15 /dev-lang/ruby/ruby-1.8.5_p12.ebuild
parentVersion bump. (diff)
downloadhistorical-6f7e40f158ac23f170ea80ab257c1dc30751fc49.tar.gz
historical-6f7e40f158ac23f170ea80ab257c1dc30751fc49.tar.bz2
historical-6f7e40f158ac23f170ea80ab257c1dc30751fc49.zip
keepdir /usr/lib/ruby/site_ruby, #90510
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-lang/ruby/ruby-1.8.5_p12.ebuild')
-rw-r--r--dev-lang/ruby/ruby-1.8.5_p12.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/ruby/ruby-1.8.5_p12.ebuild b/dev-lang/ruby/ruby-1.8.5_p12.ebuild
index 5dcede29e152..afbd88e82664 100644
--- a/dev-lang/ruby/ruby-1.8.5_p12.ebuild
+++ b/dev-lang/ruby/ruby-1.8.5_p12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p12.ebuild,v 1.1 2006/12/25 14:23:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p12.ebuild,v 1.2 2006/12/29 16:25:46 pclouds Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -100,6 +100,10 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
if use doc; then
make DESTDIR="${D}" install-doc || die "make install-doc failed"
fi