summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-05-03 02:41:39 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-05-03 02:41:39 +0000
commit0106d0a001b64718b03340bf2ac8f57b24ce8269 (patch)
tree7b6947a1862e26026c032ad6d60138171c8d7261 /dev-lang/python
parentdev-util/pkgconfig -> virtual/pkgconfig (diff)
downloadhistorical-0106d0a001b64718b03340bf2ac8f57b24ce8269.tar.gz
historical-0106d0a001b64718b03340bf2ac8f57b24ce8269.tar.bz2
historical-0106d0a001b64718b03340bf2ac8f57b24ce8269.zip
dev-util/pkgconfig -> virtual/pkgconfig
Package-Manager: portage-2.2.0_alpha101/cvs/Linux i686
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog10
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild4
-rw-r--r--dev-lang/python/python-2.6.6-r2.ebuild6
-rw-r--r--dev-lang/python/python-2.6.7-r2.ebuild6
-rw-r--r--dev-lang/python/python-2.6.8.ebuild4
-rw-r--r--dev-lang/python/python-2.7.2-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.7.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.7.3-r2.ebuild4
-rw-r--r--dev-lang/python/python-2.7.3.ebuild4
-rw-r--r--dev-lang/python/python-3.1.4-r3.ebuild4
-rw-r--r--dev-lang/python/python-3.1.4-r4.ebuild4
-rw-r--r--dev-lang/python/python-3.1.5.ebuild4
-rw-r--r--dev-lang/python/python-3.2.2-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.2.2.ebuild4
-rw-r--r--dev-lang/python/python-3.2.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-3.2.3.ebuild4
16 files changed, 41 insertions, 33 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 3552bb7e277f..bac1ae03fed1 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.589 2012/05/03 01:10:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.590 2012/05/03 02:41:39 jdhore Exp $
+
+ 03 May 2012; Jeff Horelick <jdhore@gentoo.org> python-2.5.4-r4.ebuild,
+ python-2.6.6-r2.ebuild, python-2.6.7-r2.ebuild, python-2.6.8.ebuild,
+ python-2.7.2-r3.ebuild, python-2.7.3.ebuild, python-2.7.3-r1.ebuild,
+ python-2.7.3-r2.ebuild, python-3.1.4-r3.ebuild, python-3.1.4-r4.ebuild,
+ python-3.1.5.ebuild, python-3.2.2.ebuild, python-3.2.2-r1.ebuild,
+ python-3.2.3.ebuild, python-3.2.3-r1.ebuild:
+ dev-util/pkgconfig -> virtual/pkgconfig
03 May 2012; Mike Gilbert <floppym@gentoo.org> python-3.2.3-r1.ebuild:
Revert to previous patchset due to bug 414333.
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index 35dfc9bd33cf..efb8d79f379b 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.32 2012/03/05 02:04:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.33 2012/05/03 02:41:39 jdhore Exp $
EAPI="1"
@@ -47,7 +47,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
)
doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ virtual/pkgconfig"
RDEPEND+=" !build? ( app-misc/mime-types )"
PDEPEND="app-admin/python-updater"
diff --git a/dev-lang/python/python-2.6.6-r2.ebuild b/dev-lang/python/python-2.6.6-r2.ebuild
index 63a8baa6ad2a..9276a1eec848 100644
--- a/dev-lang/python/python-2.6.6-r2.ebuild
+++ b/dev-lang/python/python-2.6.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r2.ebuild,v 1.11 2011/10/27 13:56:55 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r2.ebuild,v 1.12 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -61,7 +61,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.6.7-r2.ebuild b/dev-lang/python/python-2.6.7-r2.ebuild
index 5bd314f9a4e9..1db491b37804 100644
--- a/dev-lang/python/python-2.6.7-r2.ebuild
+++ b/dev-lang/python/python-2.6.7-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.5 2011/11/26 16:50:52 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.7-r2.ebuild,v 1.6 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -64,7 +64,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.6.8.ebuild b/dev-lang/python/python-2.6.8.ebuild
index 2a021607da76..96a8c9883ad7 100644
--- a/dev-lang/python/python-2.6.8.ebuild
+++ b/dev-lang/python/python-2.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8.ebuild,v 1.7 2012/04/28 05:02:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8.ebuild,v 1.8 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -50,7 +50,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.7.2-r3.ebuild b/dev-lang/python/python-2.7.2-r3.ebuild
index dd518c816958..81f77fb2d470 100644
--- a/dev-lang/python/python-2.7.2-r3.ebuild
+++ b/dev-lang/python/python-2.7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.11 2012/02/13 18:29:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.12 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -66,7 +66,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
DEPEND=">=sys-devel/autoconf-2.65
${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.7.3-r1.ebuild b/dev-lang/python/python-2.7.3-r1.ebuild
index bae938eb51f4..27e2404868ca 100644
--- a/dev-lang/python/python-2.7.3-r1.ebuild
+++ b/dev-lang/python/python-2.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r1.ebuild,v 1.7 2012/04/28 05:02:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r1.ebuild,v 1.8 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -51,7 +51,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.7.3-r2.ebuild b/dev-lang/python/python-2.7.3-r2.ebuild
index c5e958d8a545..261c7637b8dc 100644
--- a/dev-lang/python/python-2.7.3-r2.ebuild
+++ b/dev-lang/python/python-2.7.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r2.ebuild,v 1.3 2012/05/01 23:14:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3-r2.ebuild,v 1.4 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -51,7 +51,7 @@ RDEPEND="app-arch/bzip2
)
!!<sys-apps/portage-2.1.9"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-2.7.3.ebuild b/dev-lang/python/python-2.7.3.ebuild
index e82ac2feccb7..93c1c728646b 100644
--- a/dev-lang/python/python-2.7.3.ebuild
+++ b/dev-lang/python/python-2.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3.ebuild,v 1.2 2012/04/26 14:57:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.3.ebuild,v 1.3 2012/05/03 02:41:39 jdhore Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -55,7 +55,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
DEPEND=">=sys-devel/autoconf-2.65
${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
doc? ( dev-python/sphinx )
!sys-devel/gcc[libffi]"
diff --git a/dev-lang/python/python-3.1.4-r3.ebuild b/dev-lang/python/python-3.1.4-r3.ebuild
index ddd44c5ba546..1350eb48324e 100644
--- a/dev-lang/python/python-3.1.4-r3.ebuild
+++ b/dev-lang/python/python-3.1.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.9 2012/02/13 18:29:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.10 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -55,7 +55,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
)"
DEPEND="${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.1.4-r4.ebuild b/dev-lang/python/python-3.1.4-r4.ebuild
index 5f3649308cae..3f32dbef8e8b 100644
--- a/dev-lang/python/python-3.1.4-r4.ebuild
+++ b/dev-lang/python/python-3.1.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r4.ebuild,v 1.1 2012/03/21 16:27:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r4.ebuild,v 1.2 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -55,7 +55,7 @@ RDEPEND=">=app-admin/eselect-python-20091230
)"
DEPEND="${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.1.5.ebuild b/dev-lang/python/python-3.1.5.ebuild
index 2cee477ea3c8..7344276f20ef 100644
--- a/dev-lang/python/python-3.1.5.ebuild
+++ b/dev-lang/python/python-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5.ebuild,v 1.7 2012/04/28 05:02:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5.ebuild,v 1.8 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -41,7 +41,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.2.2-r1.ebuild b/dev-lang/python/python-3.2.2-r1.ebuild
index 5d0dd92cf49c..623d423b3010 100644
--- a/dev-lang/python/python-3.2.2-r1.ebuild
+++ b/dev-lang/python/python-3.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2-r1.ebuild,v 1.2 2012/04/26 14:58:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2-r1.ebuild,v 1.3 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -57,7 +57,7 @@ DEPEND=">=sys-devel/autoconf-2.65
${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
$([[ "${PV}" != *_pre* ]] && echo "app-arch/xz-utils")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.2.2.ebuild b/dev-lang/python/python-3.2.2.ebuild
index 139737d0b1d6..5e5a56db287e 100644
--- a/dev-lang/python/python-3.2.2.ebuild
+++ b/dev-lang/python/python-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.10 2012/03/07 19:25:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.11 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -57,7 +57,7 @@ DEPEND=">=sys-devel/autoconf-2.65
${RDEPEND}
$([[ "${PV}" == *_pre* ]] && echo "=${CATEGORY}/${PN}-${PV%%.*}*")
$([[ "${PV}" != *_pre* ]] && echo "app-arch/xz-utils")
- dev-util/pkgconfig
+ virtual/pkgconfig
$([[ "${PV}" =~ ^[[:digit:]]+\.[[:digit:]]+_pre ]] && echo "doc? ( dev-python/sphinx )")
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.2.3-r1.ebuild b/dev-lang/python/python-3.2.3-r1.ebuild
index 2dac0d7e7e4f..75b2ea35e52e 100644
--- a/dev-lang/python/python-3.2.3-r1.ebuild
+++ b/dev-lang/python/python-3.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r1.ebuild,v 1.4 2012/05/03 01:10:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3-r1.ebuild,v 1.5 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -41,7 +41,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
diff --git a/dev-lang/python/python-3.2.3.ebuild b/dev-lang/python/python-3.2.3.ebuild
index d0284e86c7e5..4e4a3587307b 100644
--- a/dev-lang/python/python-3.2.3.ebuild
+++ b/dev-lang/python/python-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.7 2012/04/28 05:02:04 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.3.ebuild,v 1.8 2012/05/03 02:41:39 jdhore Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -41,7 +41,7 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
+ virtual/pkgconfig
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )