summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-05-04 14:35:10 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-05-04 14:35:10 +0000
commit6d05f5d7123fe0877641f68010c10a0760dbbde8 (patch)
tree45312a728e0a518247e8177ce9f38f6775c833d2 /dev-lang/python/files
parentAdded ~ppc64 (diff)
downloadhistorical-6d05f5d7123fe0877641f68010c10a0760dbbde8.tar.gz
historical-6d05f5d7123fe0877641f68010c10a0760dbbde8.tar.bz2
historical-6d05f5d7123fe0877641f68010c10a0760dbbde8.zip
Fix obsd patch (thanks reb) fixing bugs 117261 and 130140.
Package-Manager: portage-2.0.54
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/digest-python-2.4.2-r22
-rw-r--r--dev-lang/python/files/digest-python-2.4.3-r12
-rw-r--r--dev-lang/python/files/python-2.4.2-gentoo_obsd-r1.patch44
-rw-r--r--dev-lang/python/files/python-2.4.3-gentoo_obsd-r1.patch35
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-lang/python/files/digest-python-2.4.2-r2 b/dev-lang/python/files/digest-python-2.4.2-r2
new file mode 100644
index 000000000000..b93384115a79
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.4.2-r2
@@ -0,0 +1,2 @@
+MD5 98db1465629693fc434d4dc52db93838 Python-2.4.2.tar.bz2 7853169
+MD5 c98f93a5700138836154d7c8009f1fbf python-2.4-patches-2.tar.bz2 9219
diff --git a/dev-lang/python/files/digest-python-2.4.3-r1 b/dev-lang/python/files/digest-python-2.4.3-r1
new file mode 100644
index 000000000000..320f967b4710
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.4.3-r1
@@ -0,0 +1,2 @@
+MD5 141c683447d5e76be1d2bd4829574f02 Python-2.4.3.tar.bz2 8005915
+MD5 c98f93a5700138836154d7c8009f1fbf python-2.4-patches-2.tar.bz2 9219
diff --git a/dev-lang/python/files/python-2.4.2-gentoo_obsd-r1.patch b/dev-lang/python/files/python-2.4.2-gentoo_obsd-r1.patch
new file mode 100644
index 000000000000..1c3a4899fc60
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.2-gentoo_obsd-r1.patch
@@ -0,0 +1,44 @@
+diff -ruN Python-2.4.2.orig/configure.in Python-2.4.2/configure.in
+--- Python-2.4.2.orig/configure.in 2005-08-07 23:08:53.000000000 +0200
++++ Python-2.4.2/configure.in 2006-04-26 16:25:03.241669250 +0200
+@@ -140,7 +140,7 @@
+ # On OpenBSD, select(2) is not available if _XOPEN_SOURCE is defined,
+ # even though select is a POSIX function. Reported by J. Ribbens.
+ # Reconfirmed for OpenBSD 3.3 by Zachary Hamm, for 3.4 by Jason Ish.
+- OpenBSD/2.* | OpenBSD/3.@<:@0123456@:>@)
++ OpenBSD/2.* | OpenBSD/3.@<:@0123456789@:>@)
+ define_xopen_source=no;;
+ # On Solaris 2.6, sys/wait.h is inconsistent in the usage
+ # of union __?sigval. Reported by Stuart Bishop.
+@@ -1517,9 +1517,16 @@
+
+ # only check for sem_ini if thread support is requested
+ if test "$with_threads" = "yes" -o -z "$with_threads"; then
++ case "$ac_sys_system" in
++ OpenBSD*)
++ LIBS="-pthread ${LIBS}"
++ ;;
++ *)
+ AC_SEARCH_LIBS(sem_init, pthread rt posix4) # 'Real Time' functions on Solaris
+ # posix4 on Solaris 2.6
+ # pthread (first!) on Linux
++ ;;
++ esac
+ fi
+
+ # check if we need libintl for locale functions
+diff -ruN Python-2.4.2.orig/Include/Python.h Python-2.4.2/Include/Python.h
+--- Python-2.4.2.orig/Include/Python.h 2004-07-27 17:57:23.000000000 +0200
++++ Python-2.4.2/Include/Python.h 2006-04-26 16:24:15.274671500 +0200
+@@ -2,6 +2,11 @@
+ #define Py_PYTHON_H
+ /* Since this is a "meta-include" file, no #ifdef __cplusplus / extern "C" { */
+
++/* Required on Gentoo/OpenBSD */
++#if defined(__OpenBSD__)
++#include <sys/types.h>
++#endif
++
+ /* Include nearly all Python header files */
+
+ #include "patchlevel.h"
diff --git a/dev-lang/python/files/python-2.4.3-gentoo_obsd-r1.patch b/dev-lang/python/files/python-2.4.3-gentoo_obsd-r1.patch
new file mode 100644
index 000000000000..ed2e3c8e4c0d
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.3-gentoo_obsd-r1.patch
@@ -0,0 +1,35 @@
+diff -Naur Python-2.4.3.orig/Include/Python.h Python-2.4.3/Include/Python.h
+--- Python-2.4.3.orig/Include/Python.h 2006-05-04 14:20:30.000000000 +0000
++++ Python-2.4.3/Include/Python.h 2006-05-04 14:21:26.000000000 +0000
+@@ -2,6 +2,11 @@
+ #define Py_PYTHON_H
+ /* Since this is a "meta-include" file, no #ifdef __cplusplus / extern "C" { */
+
++/* Required on Gentoo/OpenBSD */
++#if defined(__OpenBSD__)
++#include <sys/types.h>
++#endif
++
+ /* Include nearly all Python header files */
+
+ #include "patchlevel.h"
+diff -Naur Python-2.4.3.orig/configure.in Python-2.4.3/configure.in
+--- Python-2.4.3.orig/configure.in 2006-05-04 14:20:30.000000000 +0000
++++ Python-2.4.3/configure.in 2006-05-04 14:23:22.000000000 +0000
+@@ -1528,9 +1528,16 @@
+
+ # only check for sem_ini if thread support is requested
+ if test "$with_threads" = "yes" -o -z "$with_threads"; then
++ case "$ac_sys_system" in
++ OpenBSD*)
++ LIBS="-pthread ${LIBS}"
++ ;;
++ *)
+ AC_SEARCH_LIBS(sem_init, pthread rt posix4) # 'Real Time' functions on Solaris
+ # posix4 on Solaris 2.6
+ # pthread (first!) on Linux
++ ;;
++ esac
+ fi
+
+ # check if we need libintl for locale functions