summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-04-14 12:54:54 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-04-14 12:54:54 +0000
commit515a3a69b7eec69d672b333412f0f11ccc30f613 (patch)
tree9517c0d65b3d7be7c2576f11dfdbc60b473bb937 /dev-lang/python/files
parentUse tcltk USE flag for perl-tk dep. (diff)
downloadhistorical-515a3a69b7eec69d672b333412f0f11ccc30f613.tar.gz
historical-515a3a69b7eec69d672b333412f0f11ccc30f613.tar.bz2
historical-515a3a69b7eec69d672b333412f0f11ccc30f613.zip
Add gentoo/obsd
patch, bug 117261. Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/python-2.4.2-gentoo_obsd.patch42
-rw-r--r--dev-lang/python/files/python-2.4.3-gentoo_obsd.patch33
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-2.4.2-gentoo_obsd.patch b/dev-lang/python/files/python-2.4.2-gentoo_obsd.patch
new file mode 100644
index 000000000000..69c59747a423
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.2-gentoo_obsd.patch
@@ -0,0 +1,42 @@
+diff -ruN Python-2.4.2.orig/Include/Python.h Python-2.4.2/Include/Python.h
+--- Python-2.4.2.orig/Include/Python.h 2004-07-27 17:57:23 +0200
++++ Python-2.4.2/Include/Python.h 2006-01-01 17:50:35 +0100
+@@ -2,6 +2,9 @@
+ #define Py_PYTHON_H
+ /* Since this is a "meta-include" file, no #ifdef __cplusplus / extern "C" { */
+
++/* Required on Gentoo/OpenBSD */
++#include <sys/types.h>
++
+ /* Include nearly all Python header files */
+
+ #include "patchlevel.h"
+diff -ruN Python-2.4.2.orig/configure.in Python-2.4.2/configure.in
+--- Python-2.4.2.orig/configure.in 2005-08-07 23:08:53 +0200
++++ Python-2.4.2/configure.in 2006-01-01 17:53:27 +0100
+@@ -140,7 +140,7 @@
+ # On OpenBSD, select(2) is not available if _XOPEN_SOURCE is defined,
+ # even though select is a POSIX function. Reported by J. Ribbens.
+ # Reconfirmed for OpenBSD 3.3 by Zachary Hamm, for 3.4 by Jason Ish.
+- OpenBSD/2.* | OpenBSD/3.@<:@0123456@:>@)
++ OpenBSD/2.* | OpenBSD/3.@<:@012345678@:>@)
+ define_xopen_source=no;;
+ # On Solaris 2.6, sys/wait.h is inconsistent in the usage
+ # of union __?sigval. Reported by Stuart Bishop.
+@@ -1517,9 +1517,16 @@
+
+ # only check for sem_ini if thread support is requested
+ if test "$with_threads" = "yes" -o -z "$with_threads"; then
++ case "$ac_sys_system" in
++ OpenBSD*)
++ LIBS="-pthread ${LIBS}"
++ ;;
++ *)
+ AC_SEARCH_LIBS(sem_init, pthread rt posix4) # 'Real Time' functions on Solaris
+ # posix4 on Solaris 2.6
+ # pthread (first!) on Linux
++ ;;
++ esac
+ fi
+
+ # check if we need libintl for locale functions
diff --git a/dev-lang/python/files/python-2.4.3-gentoo_obsd.patch b/dev-lang/python/files/python-2.4.3-gentoo_obsd.patch
new file mode 100644
index 000000000000..5fe4c01d755c
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.3-gentoo_obsd.patch
@@ -0,0 +1,33 @@
+diff -ruN Python-2.4.3.orig/Include/Python.h Python-2.4.3/Include/Python.h
+--- Include/Python.h 2004-07-27 17:57:23 +0200
++++ Include/Python.h 2006-01-01 17:50:35 +0100
+@@ -2,6 +2,9 @@
+ #define Py_PYTHON_H
+ /* Since this is a "meta-include" file, no #ifdef __cplusplus / extern "C" { */
+
++/* Required on Gentoo/OpenBSD */
++#include <sys/types.h>
++
+ /* Include nearly all Python header files */
+
+ #include "patchlevel.h"
+diff -ruN Python-2.4.3.orig/configure.in Python-2.4.3/configure.in
+--- configure.in 2005-08-07 23:08:53 +0200
++++ configure.in 2006-01-01 17:53:27 +0100
+@@ -1517,9 +1517,16 @@
+
+ # only check for sem_ini if thread support is requested
+ if test "$with_threads" = "yes" -o -z "$with_threads"; then
++ case "$ac_sys_system" in
++ OpenBSD*)
++ LIBS="-pthread ${LIBS}"
++ ;;
++ *)
+ AC_SEARCH_LIBS(sem_init, pthread rt posix4) # 'Real Time' functions on Solaris
+ # posix4 on Solaris 2.6
+ # pthread (first!) on Linux
++ ;;
++ esac
+ fi
+
+ # check if we need libintl for locale functions