summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-28 15:37:38 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-28 15:37:38 +0000
commit8d98e499632870f14ed669150c88eaba08d8f2cc (patch)
treec197404f7191bca4881ea081aafcdeefaec50cff /dev-lang/pasm/files
parentx86 and alpha keywords. (diff)
downloadhistorical-8d98e499632870f14ed669150c88eaba08d8f2cc.tar.gz
historical-8d98e499632870f14ed669150c88eaba08d8f2cc.tar.bz2
historical-8d98e499632870f14ed669150c88eaba08d8f2cc.zip
Initial import of pasm
Diffstat (limited to 'dev-lang/pasm/files')
-rw-r--r--dev-lang/pasm/files/digest-pasm-1.6c1
-rw-r--r--dev-lang/pasm/files/pasm-1.6c-ppc.patch29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-lang/pasm/files/digest-pasm-1.6c b/dev-lang/pasm/files/digest-pasm-1.6c
new file mode 100644
index 000000000000..d90c9b621cbf
--- /dev/null
+++ b/dev-lang/pasm/files/digest-pasm-1.6c
@@ -0,0 +1 @@
+MD5 5bb10c13d1bae878e129cdf02ba3a9cd pasm.tar.gz 82136
diff --git a/dev-lang/pasm/files/pasm-1.6c-ppc.patch b/dev-lang/pasm/files/pasm-1.6c-ppc.patch
new file mode 100644
index 000000000000..24ff8056b937
--- /dev/null
+++ b/dev-lang/pasm/files/pasm-1.6c-ppc.patch
@@ -0,0 +1,29 @@
+diff -Naur pasm-1.6c.orig/Makefile pasm-1.6c/Makefile
+--- pasm-1.6c.orig/Makefile 2001-05-14 18:06:01.000000000 +0200
++++ pasm-1.6c/Makefile 2004-02-28 16:19:21.000000000 +0100
+@@ -14,9 +14,9 @@
+
+ # Unix
+ CC = gcc
+-COPTS = -O2 -fomit-frame-pointer -DIrix53 -DOFMT_DEFAULT=OFMT_ELF
++COPTS = $(CFLAGS) -DLinuxPPC -DOFMT_DEFAULT=OFMT_ELF
+ CLIBS = -lm
+-DIR = Irix5.3
++DIR = LinuxPPC
+
+
+ PPCobj = $(DIR)/main.o $(DIR)/support.o $(DIR)/pass.o $(DIR)/eval.o \
+diff -Naur pasm-1.6c.orig/ppcasm.h pasm-1.6c/ppcasm.h
+--- pasm-1.6c.orig/ppcasm.h 2003-11-01 13:49:29.000000000 +0100
++++ pasm-1.6c/ppcasm.h 2004-02-28 16:16:38.000000000 +0100
+@@ -162,6 +162,10 @@
+ #define MACHINE "Linux/Alpha"
+ #define LITTLEENDIAN
+ #define TYPES64BIT
++#elif defined (LinuxPPC)
++#define MACHINE "Linux/PPC"
++#define BIGENDIAN
++#define STDTYPES
+ #elif defined (Wintel) /* jab */
+ #define MACHINE "Wintel"
+ #define LITTLEENDIAN