summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
commit14edfa973223f39a6152ab0c441a0938b71a92ef (patch)
treefa6fe7d349f206462004dcb491e304b6f68b55df /dev-lang/nhc98
parentneed eutils for epatch (diff)
downloadhistorical-14edfa973223f39a6152ab0c441a0938b71a92ef.tar.gz
historical-14edfa973223f39a6152ab0c441a0938b71a92ef.tar.bz2
historical-14edfa973223f39a6152ab0c441a0938b71a92ef.zip
need eutils for epatch
Diffstat (limited to 'dev-lang/nhc98')
-rw-r--r--dev-lang/nhc98/nhc98-1.12.ebuild21
-rw-r--r--dev-lang/nhc98/nhc98-1.16-r1.ebuild25
-rw-r--r--dev-lang/nhc98/nhc98-1.16.ebuild25
3 files changed, 29 insertions, 42 deletions
diff --git a/dev-lang/nhc98/nhc98-1.12.ebuild b/dev-lang/nhc98/nhc98-1.12.ebuild
index bf65482ebcc6..b5d68da8fbbf 100644
--- a/dev-lang/nhc98/nhc98-1.12.ebuild
+++ b/dev-lang/nhc98/nhc98-1.12.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.12.ebuild,v 1.8 2003/06/12 20:31:38 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.12.ebuild,v 1.9 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL=nhc98src-${PV}.tar.gz
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="readline"
DEPEND="readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack ${A}
# patch to fix the getenv bug when tracing
cd ${P}
- patch -p0 < ${FILESDIR}/nhc98-1.12-getenv.patch
+ epatch ${FILESDIR}/nhc98-1.12-getenv.patch
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -35,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
diff --git a/dev-lang/nhc98/nhc98-1.16-r1.ebuild b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
index 1ff6082d057b..6cd2d9b056bb 100644
--- a/dev-lang/nhc98/nhc98-1.16-r1.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16-r1.ebuild,v 1.2 2003/07/11 22:14:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16-r1.ebuild,v 1.3 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL="nhc98src-${PV}.tar.gz"
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
- ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack nhc98src-${PV}.tar.gz
# type synoym patch
cd ${S}
epatch ${DISTDIR}/patch-1.16-typesyn
-# cd ${P}
-# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -39,7 +34,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
@@ -63,7 +58,7 @@ src_install () {
rm ${D}/usr/share/man/man1/hmake*
}
-pkg_postinst () {
+pkg_postinst() {
# info about new package structure
einfo "NOTICE: hmake is no longer a part of this package,"
einfo "but separately available as dev-haskell/hmake."
diff --git a/dev-lang/nhc98/nhc98-1.16.ebuild b/dev-lang/nhc98/nhc98-1.16.ebuild
index b90c57a431a0..b1fb5573dc76 100644
--- a/dev-lang/nhc98/nhc98-1.16.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.4 2003/07/11 22:14:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.5 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL="nhc98src-${PV}.tar.gz"
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
- ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack nhc98src-${PV}.tar.gz
# type synoym patch
cd ${S}
epatch ${DISTDIR}/patch-1.16-typesyn
-# cd ${P}
-# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -39,7 +34,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
@@ -54,7 +49,7 @@ src_install () {
dodoc bugs/README
}
-pkg_postinst () {
+pkg_postinst() {
#nhc's build system does not update hmakerc when using DESTDIR;
#therefore, we do it manually here