summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-04-11 18:39:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-04-11 18:39:21 +0000
commitbfce3b7423fcb107fc9ec93d9f3fe2b997fd0fcd (patch)
treed50fdb78f0332d703079cf932464137c43389ad4 /dev-lang/nasm/nasm-2.09.08.ebuild
parentSet SUPPORT_PYTHON_ABIS (bug #345541). (diff)
downloadhistorical-bfce3b7423fcb107fc9ec93d9f3fe2b997fd0fcd.tar.gz
historical-bfce3b7423fcb107fc9ec93d9f3fe2b997fd0fcd.tar.bz2
historical-bfce3b7423fcb107fc9ec93d9f3fe2b997fd0fcd.zip
version bump
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'dev-lang/nasm/nasm-2.09.08.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.09.08.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.09.08.ebuild b/dev-lang/nasm/nasm-2.09.08.ebuild
new file mode 100644
index 000000000000..ce4267897f56
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.09.08.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.09.08.ebuild,v 1.1 2011/04/11 18:39:21 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://nasm.sourceforge.net/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
+RDEPEND=""
+
+S=${WORKDIR}/${P/_}
+
+src_configure() {
+ strip-flags
+ econf
+}
+
+src_compile() {
+ emake nasmlib.o || die
+ emake all || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install install_rdf || die
+ dodoc AUTHORS CHANGES ChangeLog README TODO
+ if use doc ; then
+ doinfo doc/info/*
+ dohtml doc/html/*
+ dodoc doc/nasmdoc.*
+ fi
+}