summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-26 13:50:12 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-26 13:50:12 +0000
commitc1bcff63e18c4bdf42694a046c5b4e9028371744 (patch)
tree9c147287750b1768339c539be95b7ebcd02196c0 /dev-lang/ghc
parenttouchups (diff)
downloadhistorical-c1bcff63e18c4bdf42694a046c5b4e9028371744.tar.gz
historical-c1bcff63e18c4bdf42694a046c5b4e9028371744.tar.bz2
historical-c1bcff63e18c4bdf42694a046c5b4e9028371744.zip
Modified CFLAG testing code, following discussion in bug #59709.
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/ghc-6.2.2.ebuild23
3 files changed, 16 insertions, 16 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index c71ef24c84cb..deb5e3ccf678 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.44 2004/10/23 23:14:49 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.45 2004/10/26 13:50:12 kosmikus Exp $
+
+ 26 Oct 2004; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.2.ebuild:
+ Modified CFLAG testing code, following discussion in bug #59709.
24 Oct 2004; Matthieu Sozeau <mattam@gentoo.org> ghc-6.2.2.ebuild:
Tested on ppc.
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index 32f26fef59c6..83ee416b3a1f 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,8 +1,8 @@
MD5 fea7650a5492528d515692c8a26f1ab8 ghc-6.2.1-r1.ebuild 5790
MD5 cdc2c51fea57a0f87af76599f73c64f8 ghc-6.2.ebuild 5000
MD5 1bab1224823b1bdf22fe21cbf40d8a56 ghc-6.0.1.ebuild 4709
-MD5 6c6513e9b37f604cc0907b31f1544487 ghc-6.2.2.ebuild 4748
-MD5 7086ab5e0a75bc531dea1f43e2ef5888 ChangeLog 8844
+MD5 122a3cf76eff7f0af3ab087dd4277193 ghc-6.2.2.ebuild 4730
+MD5 1fb3de6853518ec7296c3326095353e8 ChangeLog 8981
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 700ce4a5a2ed7953404345f57ac8bbc7 ghc-6.2-r1.ebuild 5182
MD5 627087e51858d514520531cedbd372f8 files/ghc-6.2.1-linker.patch.bz2 658
diff --git a/dev-lang/ghc/ghc-6.2.2.ebuild b/dev-lang/ghc/ghc-6.2.2.ebuild
index aad6ea2850bd..f156155b51bc 100644
--- a/dev-lang/ghc/ghc-6.2.2.ebuild
+++ b/dev-lang/ghc/ghc-6.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.2 2004/10/23 23:14:49 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.3 2004/10/26 13:50:12 kosmikus Exp $
# Brief explanation of the bootstrap logic:
#
@@ -61,20 +61,16 @@ GHCPATH="${PATH}:/opt/ghc/bin"
SUPPORTED_CFLAGS=""
# Setup supported CFLAGS.
-setup_cflag() {
+check_cflags() {
OLD_CFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} $1"
+ CFLAGS="$1"
strip-unsupported-flags
-
- if [ "${OLD_CFLAGS}" != "${CFLAGS}" ];
- then
- SUPPORTED_CFLAGS="$1 ${SUPPORTED_CFLAGS}"
- fi
+ SUPPORTED_CFLAGS="${SUPPORTED_CFLAGS} ${CFLAGS}"
+ CFLAGS="${OLD_CFLAGS}"
}
setup_cflags() {
- setup_cflag "-fno-pic"
- setup_cflag "-fno-stack-protector"
+ check_cflags "-nopie -fno-stack-protector -fno-stack-protector-all"
}
src_unpack() {
@@ -86,9 +82,10 @@ src_unpack() {
cd ${S}/ghc
pushd driver
setup_cflags
+
epatch ${FILESDIR}/${PN}-6.2.hardened.patch
- sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS//-f/-optc-f}|" ghc/ghc.sh
- sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS//-f/-optc-f}|" ghci/ghci.sh
+ sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS// -/ -optc-}|" ghc/ghc.sh
+ sed -i -e "s|@GHC_CFLAGS@|${SUPPORTED_CFLAGS// -/ -optc-}|" ghci/ghci.sh
popd
}
@@ -105,7 +102,7 @@ src_compile() {
# patch included)
setup_cflags
echo "SRC_CC_OPTS+=${SUPPORTED_CFLAGS}" >> mk/build.mk
- echo "SRC_HC_OPTS+=${SUPPORTED_CFLAGS//-f/-optc-f}" >> mk/build.mk
+ echo "SRC_HC_OPTS+=${SUPPORTED_CFLAGS// -/ -optc-}" >> mk/build.mk
# force the config variable ArSupportsInput to be unset;
# ar in binutils >= 2.14.90.0.8-r1 seems to be classified