summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:39:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:39:13 +0000
commitf94a1aa601b67d627087ef7e3b076c8d32dc3662 (patch)
tree915c9e838a3b858e60d88933761c911954997727 /dev-lang/cm3-bin
parentold (diff)
downloadhistorical-f94a1aa601b67d627087ef7e3b076c8d32dc3662.tar.gz
historical-f94a1aa601b67d627087ef7e3b076c8d32dc3662.tar.bz2
historical-f94a1aa601b67d627087ef7e3b076c8d32dc3662.zip
use $(tc-getCC)
Diffstat (limited to 'dev-lang/cm3-bin')
-rw-r--r--dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild b/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild
index 1cb890d0f3b5..c309c8561ae4 100644
--- a/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild
+++ b/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild,v 1.7 2004/06/24 22:47:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3-bin/cm3-bin-5.2.6.ebuild,v 1.8 2004/10/26 13:36:44 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Critical Mass Modula-3 compiler (binary version)"
HOMEPAGE="http://www.elegosoft.com/cm3/"
@@ -21,11 +23,11 @@ src_unpack() {
local TARGET
local GNU_PLATFORM
case ${ARCH} in
- x86) TARGET=LINUXLIBC6
- GNU_PLATFORM=i486--linuxelf
+ x86) TARGET=LINUXLIBC6
+ GNU_PLATFORM=i486--linuxelf
;;
- ppc) TARGET=PPC_LINUX
- GNU_PLATFORM=powerpc-apple-linuxelf
+ ppc) TARGET=PPC_LINUX
+ GNU_PLATFORM=powerpc-apple-linuxelf
;;
esac
sed \
@@ -33,7 +35,7 @@ src_unpack() {
-e "s:GENTOO_GNU_PLATFORM:${GNU_PLATFORM}:" \
-e "s:GENTOO_INITIAL_REACTOR_EDITOR:${EDITOR:-/usr/bin/nano}:" \
-e "s:GENTOO_INSTALL_ROOT:/usr/lib/cm3/:" \
- -e "s:GENTOO_GNU_CC:${CC:-gcc}:" \
+ -e "s:GENTOO_GNU_CC:$(tc-getCC):" \
-e "s:GENTOO_GNU_CFLAGS:${CFLAGS:--O}:" \
-e "s:GENTOO_GNU_MAKE:${MAKE:-make}:" \
-e "s:GENTOO_ROOT:/usr/lib/cm3/pkg/:" \