summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-10 22:33:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-10 22:33:28 +0000
commita7aee7e1de27f3eb78fc8a97c60bf85bb1b4f4eb (patch)
tree7b86e9ccc35407d162e7f229e78585e623d181be /dev-lang/R/R-2.2.1.ebuild
parentVersion bump #129528 by Natanael Copa. (diff)
downloadhistorical-a7aee7e1de27f3eb78fc8a97c60bf85bb1b4f4eb.tar.gz
historical-a7aee7e1de27f3eb78fc8a97c60bf85bb1b4f4eb.tar.bz2
historical-a7aee7e1de27f3eb78fc8a97c60bf85bb1b4f4eb.zip
touchups
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'dev-lang/R/R-2.2.1.ebuild')
-rw-r--r--dev-lang/R/R-2.2.1.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-lang/R/R-2.2.1.ebuild b/dev-lang/R/R-2.2.1.ebuild
index 863b48b53033..e00cd2053ea4 100644
--- a/dev-lang/R/R-2.2.1.ebuild
+++ b/dev-lang/R/R-2.2.1.ebuild
@@ -1,13 +1,18 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.4 2006/04/01 14:34:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.5 2006/04/10 22:33:28 vapier Exp $
inherit fortran toolchain-funcs
-IUSE="blas jpeg nls png readline tcltk X lapack"
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas jpeg nls png readline tcltk X lapack"
+
RDEPEND=">=dev-lang/perl-5.6.1-r3
readline? ( >=sys-libs/readline-4.1-r3 )
jpeg? ( >=media-libs/jpeg-6b-r2 )
@@ -22,15 +27,13 @@ DEPEND="${RDEPEND}
x11-libs/libXt
x11-libs/libX11 )
virtual/x11 ) )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
AT_M4DIR="${S}/m4"
pkg_setup() {
# Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
# Thanks to vapier for providing the test.
- cd ${T}
+ cd "${T}"
echo 'int main(){}' > test.c
$(tc-getCC) -c test.c -o test.o
if file test.o | grep -qs 64-bit ; then