summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-22 11:23:17 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-22 11:23:17 +0000
commit4d2d0cd045ace1e881f6b5e11a49ea7a7d2eabcd (patch)
tree56000cbf87b2d8f851fd736131cac802d3b316e3 /dev-lang/R/R-1.8.1.ebuild
parentInitial import (diff)
downloadhistorical-4d2d0cd045ace1e881f6b5e11a49ea7a7d2eabcd.tar.gz
historical-4d2d0cd045ace1e881f6b5e11a49ea7a7d2eabcd.tar.bz2
historical-4d2d0cd045ace1e881f6b5e11a49ea7a7d2eabcd.zip
Fixing bug #40100 (problems with newer Xfree)
Diffstat (limited to 'dev-lang/R/R-1.8.1.ebuild')
-rw-r--r--dev-lang/R/R-1.8.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-lang/R/R-1.8.1.ebuild b/dev-lang/R/R-1.8.1.ebuild
index 7a43c31a6d2d..bbed92a564dc 100644
--- a/dev-lang/R/R-1.8.1.ebuild
+++ b/dev-lang/R/R-1.8.1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.2 2004/03/01 04:55:10 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.3 2004/03/22 11:23:17 phosphan Exp $
IUSE="atlas X tcltk gnome"
-S=${WORKDIR}/${P}
-
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
@@ -38,6 +36,13 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's/^#define NeedFunctionPrototypes 0/#define NeedFunctionPrototypes 1/' \
+ -i src/modules/X11/dataentry.c || die "sed failed"
+}
+
src_compile() {
local myconf="--enable-R-profiling --enable-R-shlib --with-readline"