summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-12-08 11:50:40 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-12-08 11:50:40 +0000
commitb466dd8d115094535943c29b7550ef892a2f89f5 (patch)
tree971bf8b01b685341df3f5f50994089daa58e05f5 /dev-java
parentEbuilds for 0.5* should have ~arch instead of arch. sorry (diff)
downloadhistorical-b466dd8d115094535943c29b7550ef892a2f89f5.tar.gz
historical-b466dd8d115094535943c29b7550ef892a2f89f5.tar.bz2
historical-b466dd8d115094535943c29b7550ef892a2f89f5.zip
commons-httpclient only needs ant-core to compile instead of full ant. Part of bug #110337.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-httpclient/ChangeLog7
-rw-r--r--dev-java/commons-httpclient/Manifest14
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild6
3 files changed, 21 insertions, 6 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
index 41e47285e32f..cf1e308ec6f7 100644
--- a/dev-java/commons-httpclient/ChangeLog
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-httpclient
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.24 2005/11/11 23:00:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.25 2005/12/08 11:50:40 betelgeuse Exp $
+
+ 08 Dec 2005; Petteri Räty <betelgeuse@gentoo.org>
+ commons-httpclient-3.0_rc4.ebuild:
+ commons-httpclient only needs ant-core to compile instead of full ant. Part
+ of bug #110337.
11 Nov 2005; Michael Hanselmann <hansmi@gentoo.org>
commons-httpclient-2.0.2.ebuild:
diff --git a/dev-java/commons-httpclient/Manifest b/dev-java/commons-httpclient/Manifest
index 97461233a732..472d0dd2b7d9 100644
--- a/dev-java/commons-httpclient/Manifest
+++ b/dev-java/commons-httpclient/Manifest
@@ -1,10 +1,20 @@
-MD5 76c61282e87dee42eef96d2343678c83 ChangeLog 3639
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 17bd33c3929f345e09f6b4a7742346b3 ChangeLog 3830
MD5 85a7cd05a7569930a02041ec5cda33ee commons-httpclient-2.0.1.ebuild 1692
MD5 f4ff23536c978a54310fd4476af75770 commons-httpclient-2.0.2.ebuild 1703
-MD5 3d8517ce16432ac037a2942ca713c02a commons-httpclient-3.0_rc4.ebuild 1418
+MD5 04223725dbac85a210eaddf314674afe commons-httpclient-3.0_rc4.ebuild 1442
MD5 22c430c6bf50bc578f8095df5fd64cc4 files/digest-commons-httpclient-2.0.1 81
MD5 63acee983ed2a9669cd20bc47743b8d3 files/digest-commons-httpclient-2.0.2 81
MD5 d2322c9e0f16e39e0c351e74433faf6f files/digest-commons-httpclient-3.0_rc4 83
MD5 35bcb566781a909ae25bac9979bf497c files/gentoo.diff 444
MD5 20316ee59dc3bf35dd5c04778ae6882f files/jikes.diff 955
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDmB4eQiJ/wx066S4RAmumAJ0ftuLzazs23uIoPCh/VCrbJzapTgCeP2zq
+3Eg71XDeF71DI3XuG8owVrY=
+=9zWp
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild b/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild
index 6799d9932783..3ff79169fbd1 100644
--- a/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild
+++ b/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild,v 1.1 2005/11/02 14:24:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-3.0_rc4.ebuild,v 1.2 2005/12/08 11:50:40 betelgeuse Exp $
inherit java-pkg eutils
@@ -21,7 +21,7 @@ RDEPEND=">=virtual/jre-1.3
DEPEND=">=virtual/jdk-1.3
sys-apps/sed
- >=dev-java/ant-1.4
+ >=dev-java/ant-core-1.4
junit? ( dev-java/junit )
source? ( app-arch/zip )
${RDEPEND}"
@@ -34,7 +34,7 @@ src_unpack() {
mkdir lib && cd lib
java-pkg_jar-from commons-logging
java-pkg_jar-from commons-codec
- java-pkg_jar-from junit
+ use junit && java-pkg_jar-from junit
}
src_compile() {