summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2004-01-17 03:06:50 +0000
committerAdrian Almenar <strider@gentoo.org>2004-01-17 03:06:50 +0000
commitafc0796b63c150c35f79d01f9de05215668c2f02 (patch)
tree0b71238793aef180580e64f87015e261e8937d65 /dev-java/oro/oro-2.0.8.ebuild
parentmove to x86 stable (diff)
downloadhistorical-afc0796b63c150c35f79d01f9de05215668c2f02.tar.gz
historical-afc0796b63c150c35f79d01f9de05215668c2f02.tar.bz2
historical-afc0796b63c150c35f79d01f9de05215668c2f02.zip
Version bump.
Diffstat (limited to 'dev-java/oro/oro-2.0.8.ebuild')
-rw-r--r--dev-java/oro/oro-2.0.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/oro/oro-2.0.8.ebuild b/dev-java/oro/oro-2.0.8.ebuild
new file mode 100644
index 000000000000..812d2c0dc1c6
--- /dev/null
+++ b/dev-java/oro/oro-2.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.8.ebuild,v 1.1 2004/01/17 03:06:49 strider Exp $
+
+DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
+HOMEPAGE="http://jakarta.apache.org/oro/index.html"
+SRC_URI="mirror://apache/jakarta/oro/source/jakarta-${PN}-${PV}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+
+S=${WORKDIR}/jakarta-oro-${PV}
+
+src_compile() {
+ local myc
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ ANT_OPTS=${myc} ant jar || die "Failed Compiling"
+
+ if [ -n "`use doc`" ] ; then
+ ant javadocs || die "Failed Creating Docs"
+ fi
+}
+
+src_install() {
+ mv jakarta-oro*.jar oro.jar
+ dojar oro.jar || die "Failed Installing"
+ dodoc CHANGES COMPILE CONTRIBUTORS ISSUES LICENSE README STYLE TODO
+ dohtml *.html
+
+ [ -n "`use doc`" ] && dohtml -r docs/
+}