summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-11 12:31:50 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-11 12:31:50 +0000
commitd8cba3a0b303434a02f18fd09cae475160d120e7 (patch)
tree1b5457f6ea71679a8dff106164688ea771446c89 /dev-java/jcommon/jcommon-0.9.7-r2.ebuild
parentFixing built_with_use checks for non-existant IUSE ( bug #147134 ) and merge ... (diff)
downloadhistorical-d8cba3a0b303434a02f18fd09cae475160d120e7.tar.gz
historical-d8cba3a0b303434a02f18fd09cae475160d120e7.tar.bz2
historical-d8cba3a0b303434a02f18fd09cae475160d120e7.zip
Migrated to new Java build system.
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-java/jcommon/jcommon-0.9.7-r2.ebuild')
-rw-r--r--dev-java/jcommon/jcommon-0.9.7-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/jcommon/jcommon-0.9.7-r2.ebuild b/dev-java/jcommon/jcommon-0.9.7-r2.ebuild
new file mode 100644
index 000000000000..079275ef9d4c
--- /dev/null
+++ b/dev-java/jcommon/jcommon-0.9.7-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7-r2.ebuild,v 1.1 2006/09/11 12:31:50 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects."
+HOMEPAGE="http://www.jfree.org"
+SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ dev-java/junit"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ rm *.jar
+
+}
+
+src_compile() {
+
+ local antflags="compile"
+ use doc && antflags="${antflags} javadoc"
+ eant -f ant/build.xml ${antflags} || die "compile failed"
+
+}
+
+src_install() {
+
+ java-pkg_newjar ${P}.jar ${PN}.jar
+ dodoc README.txt
+ use doc && java-pkg_dohtml -r javadoc
+ use source && java-pkg_dosrc source/*
+
+}