summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-12 12:01:18 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-12 12:01:18 +0000
commit174afbed485f39527e4a9a558ef90d978bf5fefb (patch)
tree165acffcee50946f79020dd425ebe2712b4f6fb4 /dev-java/hessian/hessian-3.1.6.ebuild
parentpam_mount bumped to cover upstream changed tarball (diff)
downloadhistorical-174afbed485f39527e4a9a558ef90d978bf5fefb.tar.gz
historical-174afbed485f39527e4a9a558ef90d978bf5fefb.tar.bz2
historical-174afbed485f39527e4a9a558ef90d978bf5fefb.zip
Version bump.
Package-Manager: portage-2.1.5.5
Diffstat (limited to 'dev-java/hessian/hessian-3.1.6.ebuild')
-rw-r--r--dev-java/hessian/hessian-3.1.6.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/hessian/hessian-3.1.6.ebuild b/dev-java/hessian/hessian-3.1.6.ebuild
new file mode 100644
index 000000000000..cee4a8c23797
--- /dev/null
+++ b/dev-java/hessian/hessian-3.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-3.1.6.ebuild,v 1.1 2008/06/12 12:01:17 nelchael Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Binary web service protocol."
+HOMEPAGE="http://hessian.caucho.com/"
+SRC_URI="http://hessian.caucho.com/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+COMMON_DEP="java-virtuals/servlet-api:2.4"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+EANT_BUILD_TARGET="all"
+
+S="${WORKDIR}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ mkdir -p "${S}/src"
+ mkdir -p "${S}/lib"
+
+ cp "${FILESDIR}/build.xml-${PV}" "${S}/build.xml"
+
+ cd "${S}/src"
+ mv ../com .
+
+ cd "${S}/lib"
+ java-pkg_jarfrom --virtual servlet-api:2.4
+
+}
+
+src_install() {
+
+ java-pkg_dojar "hessian.jar"
+ java-pkg_dojar "burlap.jar"
+ java-pkg_dojar "services.jar"
+
+ use source && java-pkg_dosrc src
+
+}