summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-02 18:01:37 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-02 18:01:37 +0000
commitb9c6b2de5a3601f416745335be42012e04d8be8e (patch)
tree1d8eb7d7cfaf37cafcbefda09c3f2a3b907ceff6 /dev-haskell
parentRemoved old. (diff)
downloadhistorical-b9c6b2de5a3601f416745335be42012e04d8be8e.tar.gz
historical-b9c6b2de5a3601f416745335be42012e04d8be8e.tar.bz2
historical-b9c6b2de5a3601f416745335be42012e04d8be8e.zip
Version bump.
Package-Manager: portage-2.1.10.7/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hunit/ChangeLog7
-rw-r--r--dev-haskell/hunit/hunit-1.2.2.3.ebuild40
-rw-r--r--dev-haskell/iconv/ChangeLog9
-rw-r--r--dev-haskell/iconv/iconv-0.4.1.0.ebuild23
4 files changed, 76 insertions, 3 deletions
diff --git a/dev-haskell/hunit/ChangeLog b/dev-haskell/hunit/ChangeLog
index 40e1bb52fba4..b03baf197312 100644
--- a/dev-haskell/hunit/ChangeLog
+++ b/dev-haskell/hunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hunit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.42 2011/06/05 13:10:15 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/ChangeLog,v 1.43 2011/08/02 17:56:47 slyfox Exp $
+
+*hunit-1.2.2.3 (02 Aug 2011)
+
+ 02 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> +hunit-1.2.2.3.ebuild:
+ Version bump.
05 Jun 2011; Sergei Trofimovich <slyfox@gentoo.org> -hunit-1.1.ebuild,
-hunit-1.1-r1.ebuild, -hunit-1.1.1.ebuild, -hunit-1.2.0.0.ebuild:
diff --git a/dev-haskell/hunit/hunit-1.2.2.3.ebuild b/dev-haskell/hunit/hunit-1.2.2.3.ebuild
new file mode 100644
index 000000000000..003432b2d630
--- /dev/null
+++ b/dev-haskell/hunit/hunit-1.2.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hunit/hunit-1.2.2.3.ebuild,v 1.1 2011/08/02 17:56:47 slyfox Exp $
+
+# ebuild generated by hackport 0.2.9
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+MY_PN="HUnit"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A unit testing framework for Haskell"
+HOMEPAGE="http://hunit.sourceforge.net/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ cabal_src_install
+ if use doc; then
+ dohtml -r "${S}/doc/"*
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove hunit self-tests, we don't want to install them
+ rm -rf "${D}/usr/bin"
+}
diff --git a/dev-haskell/iconv/ChangeLog b/dev-haskell/iconv/ChangeLog
index c03a01b2481d..32eb62f6656c 100644
--- a/dev-haskell/iconv/ChangeLog
+++ b/dev-haskell/iconv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/iconv
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/iconv/ChangeLog,v 1.2 2009/11/09 18:59:23 kolmodin Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/iconv/ChangeLog,v 1.3 2011/08/02 18:01:37 slyfox Exp $
+
+*iconv-0.4.1.0 (02 Aug 2011)
+
+ 02 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> +iconv-0.4.1.0.ebuild:
+ Version bump.
*iconv-0.4.0.2 (09 Nov 2009)
diff --git a/dev-haskell/iconv/iconv-0.4.1.0.ebuild b/dev-haskell/iconv/iconv-0.4.1.0.ebuild
new file mode 100644
index 000000000000..0ffad601a9c9
--- /dev/null
+++ b/dev-haskell/iconv/iconv-0.4.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/iconv/iconv-0.4.1.0.ebuild,v 1.1 2011/08/02 18:01:37 slyfox Exp $
+
+# ebuild generated by hackport 0.2.12
+
+EAPI="2"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="String encoding conversion"
+HOMEPAGE="http://hackage.haskell.org/package/iconv"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"