summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-20 15:56:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-20 15:56:53 +0000
commit2ff0d8be78103263d43dac60dbfc30226f7c60b9 (patch)
tree4b290099bef1bf7ff60d56e53603c1b1e9c2a5b5 /dev-haskell
parentVersion bump. (diff)
downloadhistorical-2ff0d8be78103263d43dac60dbfc30226f7c60b9.tar.gz
historical-2ff0d8be78103263d43dac60dbfc30226f7c60b9.tar.bz2
historical-2ff0d8be78103263d43dac60dbfc30226f7c60b9.zip
Fix build breakage on <ghc-7.4.
Package-Manager: portage-2.2.0_alpha90_p19/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/binary/ChangeLog5
-rw-r--r--dev-haskell/binary/binary-0.5.1.0.ebuild7
-rw-r--r--dev-haskell/extensible-exceptions/ChangeLog6
-rw-r--r--dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild11
-rw-r--r--dev-haskell/hpc/ChangeLog5
-rw-r--r--dev-haskell/hpc/hpc-0.5.1.1.ebuild9
6 files changed, 19 insertions, 24 deletions
diff --git a/dev-haskell/binary/ChangeLog b/dev-haskell/binary/ChangeLog
index 8a7873efd44a..70026e053259 100644
--- a/dev-haskell/binary/ChangeLog
+++ b/dev-haskell/binary/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/binary
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/ChangeLog,v 1.16 2012/03/04 02:19:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/ChangeLog,v 1.17 2012/03/20 15:56:53 slyfox Exp $
+
+ 20 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> binary-0.5.1.0.ebuild:
+ Fix build breakage on <ghc-7.4.
*binary-0.5.1.0 (04 Mar 2012)
diff --git a/dev-haskell/binary/binary-0.5.1.0.ebuild b/dev-haskell/binary/binary-0.5.1.0.ebuild
index bf2a00326717..3074974749cd 100644
--- a/dev-haskell/binary/binary-0.5.1.0.ebuild
+++ b/dev-haskell/binary/binary-0.5.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/binary-0.5.1.0.ebuild,v 1.1 2012/03/04 02:19:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/binary/binary-0.5.1.0.ebuild,v 1.2 2012/03/20 15:56:53 slyfox Exp $
# ebuild generated by hackport 0.2.13
@@ -9,9 +9,6 @@ EAPI="3"
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
-MY_PV=$(get_version_component_range '1-3')
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
HOMEPAGE="http://code.haskell.org/binary/"
SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
@@ -25,6 +22,4 @@ RDEPEND=">=dev-lang/ghc-6.8.2"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
CABAL_CORE_LIB_GHC_PV="7.4.0.20111219 7.4.0.20120126 7.4.1"
diff --git a/dev-haskell/extensible-exceptions/ChangeLog b/dev-haskell/extensible-exceptions/ChangeLog
index 3a66be588365..9fb9ef9eeb81 100644
--- a/dev-haskell/extensible-exceptions/ChangeLog
+++ b/dev-haskell/extensible-exceptions/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/extensible-exceptions
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/extensible-exceptions/ChangeLog,v 1.1 2012/03/04 03:11:43 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/extensible-exceptions/ChangeLog,v 1.2 2012/03/20 15:55:37 slyfox Exp $
+
+ 20 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ extensible-exceptions-0.1.1.4.ebuild:
+ Fix build breakage on <ghc-7.4.
*extensible-exceptions-0.1.1.4 (04 Mar 2012)
diff --git a/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild b/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild
index 4ae398fabfc9..3a687eb7b90a 100644
--- a/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild
+++ b/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild,v 1.1 2012/03/04 03:11:43 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/extensible-exceptions/extensible-exceptions-0.1.1.4.ebuild,v 1.2 2012/03/20 15:55:37 slyfox Exp $
EAPI="3"
CABAL_FEATURES="lib profile haddock hscolour hoogle"
-inherit haskell-cabal versionator
-
-MY_PV=$(get_version_component_range '1-3')
-MY_P="${PN}-${PV}"
+inherit haskell-cabal
DESCRIPTION="Extensible exceptions"
HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/extensible-exceptions"
@@ -16,13 +13,11 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
RDEPEND=">=dev-lang/ghc-6.8.1"
DEPEND=">=dev-haskell/cabal-1.6
${RDEPEND}"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
CABAL_CORE_LIB_GHC_PV="7.4.0.20111219 7.4.0.20120126 7.4.1"
diff --git a/dev-haskell/hpc/ChangeLog b/dev-haskell/hpc/ChangeLog
index 16565c1d367b..75c0edae4070 100644
--- a/dev-haskell/hpc/ChangeLog
+++ b/dev-haskell/hpc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/hpc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hpc/ChangeLog,v 1.3 2012/03/04 03:30:06 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hpc/ChangeLog,v 1.4 2012/03/20 15:54:52 slyfox Exp $
+
+ 20 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> hpc-0.5.1.1.ebuild:
+ Fix build breakage on <ghc-7.4.
*hpc-0.5.1.1 (04 Mar 2012)
diff --git a/dev-haskell/hpc/hpc-0.5.1.1.ebuild b/dev-haskell/hpc/hpc-0.5.1.1.ebuild
index 7097d080a5b0..0078831aae6d 100644
--- a/dev-haskell/hpc/hpc-0.5.1.1.ebuild
+++ b/dev-haskell/hpc/hpc-0.5.1.1.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hpc/hpc-0.5.1.1.ebuild,v 1.1 2012/03/04 03:30:06 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hpc/hpc-0.5.1.1.ebuild,v 1.2 2012/03/20 15:54:52 slyfox Exp $
EAPI="3"
CABAL_FEATURES="lib profile haddock hscolour hoogle"
-inherit haskell-cabal versionator
-
-MY_PV=$(get_version_component_range '1-3')
-MY_P="${MY_PN}-${PV}"
+inherit haskell-cabal
DESCRIPTION="Code Coverage Library for Haskell"
HOMEPAGE="http://hackage.haskell.org/package/hpc"
@@ -23,6 +20,4 @@ RDEPEND=">=dev-lang/ghc-6.10.1"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
CABAL_CORE_LIB_GHC_PV="7.4.0.20111219 7.4.0.20120126 7.4.1"