summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:27:53 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:27:53 +0000
commit7e23e2b23452b1a4595cb098f287cce8367245f6 (patch)
tree5db36c13919aff9ebdf8c658d135ac71f1abfaec /dev-haskell/hmake
parentadded hdoc ebuild (diff)
downloadhistorical-7e23e2b23452b1a4595cb098f287cce8367245f6.tar.gz
historical-7e23e2b23452b1a4595cb098f287cce8367245f6.tar.bz2
historical-7e23e2b23452b1a4595cb098f287cce8367245f6.zip
added hmake ebuild
Diffstat (limited to 'dev-haskell/hmake')
-rw-r--r--dev-haskell/hmake/ChangeLog11
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.071
-rw-r--r--dev-haskell/hmake/hmake-3.07.ebuild53
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
new file mode 100644
index 000000000000..4d8bb8d3ab79
--- /dev/null
+++ b/dev-haskell/hmake/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/hmake
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.1 2003/04/22 08:27:53 kosmikus Exp $
+
+*hmake-3.07 (22 Apr 2003)
+
+ 22 Apr 2003; Andres Loeh <kosmikus@gentoo.org> all :
+
+ Initial import. Thanks to Thomas L. Bevan <tom@regex.com.au> for submitting an
+ ebuild (#3970). hmake is a make-like tool that can be used with the major Haskell
+ compilers (i.e. ghc, nhc98, hbc).
diff --git a/dev-haskell/hmake/files/digest-hmake-3.07 b/dev-haskell/hmake/files/digest-hmake-3.07
new file mode 100644
index 000000000000..82ef897eed46
--- /dev/null
+++ b/dev-haskell/hmake/files/digest-hmake-3.07
@@ -0,0 +1 @@
+MD5 db1f290731c075628f60a59667c97434 hmake-3.07.tar.gz 72561
diff --git a/dev-haskell/hmake/hmake-3.07.ebuild b/dev-haskell/hmake/hmake-3.07.ebuild
new file mode 100644
index 000000000000..ae724c91c122
--- /dev/null
+++ b/dev-haskell/hmake/hmake-3.07.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.07.ebuild,v 1.1 2003/04/22 08:27:53 kosmikus Exp $
+
+DESCRIPTION="a make tool for Haskell programs"
+
+HOMEPAGE="http://www.haskell.org/hmake/"
+
+LICENSE="nhc98"
+
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="nhc98"
+
+# hmake can be build with either ghc or nhc98; we prefer ghc
+# unless a use flag tells us otherwise
+DEPEND="nhc98? ( dev-lang/nhc98 )
+ !nhc98? ( virtual/ghc )"
+
+RDEPEND="${DEPEND}"
+
+SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
+
+src_compile() {
+ if [ "`use nhc98`" ]; then
+ buildwith="--buildwith=nhc98"
+ # Makefile is erroneous; we need to fix it
+ pushd hmake-3.07
+ mv Makefile Makefile.orig
+ sed -e "s/^TARGETS.*=/TARGETS = hmake-nhc hi-nhc/" \
+ Makefile.orig > Makefile
+ popd
+ else
+ buildwith="--buildwith=ghc"
+ fi
+ # package uses non-standard configure, therefore econf does
+ # not work ...
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ ${buildwith} || die "./configure failed"
+
+ # emake tested; does not work
+ make || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # install HTML documentation
+ cd docs/hmake
+ dohtml *
+}