summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
commit85c89a6a1e184e931c2ea612675ecda59bb299d3 (patch)
tree1664d9add2584720f897a268ab95f2b26fc8faa3 /dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
parentStable on ppc. (diff)
downloadhistorical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.gz
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.bz2
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.zip
New 1.0 version of HDBC and backends.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild')
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
new file mode 100644
index 000000000000..43ca014dca23
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild,v 1.1 2006/07/02 19:09:49 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+DESCRIPTION="Sqlite v3 database driver for HDBC"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}3_${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=virtual/ghc-6.4.1
+ ~dev-haskell/hdbc-${hdbc_PV}
+ >=dev-db/sqlite-3.2"
+
+S="${WORKDIR}/${PN}3"