summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-09-14 10:52:08 +0000
committerMark Wright <gienah@gentoo.org>2012-09-14 10:52:08 +0000
commitac68903f169668488909942f27c91289a6ba14d9 (patch)
treecc980066ab6723aced97d1d7cf21bca3e4374a4d /dev-haskell/deepseq/deepseq-1.3.0.1.ebuild
parentFixed separators in sed substitute commands to not collide with path separato... (diff)
downloadhistorical-ac68903f169668488909942f27c91289a6ba14d9.tar.gz
historical-ac68903f169668488909942f27c91289a6ba14d9.tar.bz2
historical-ac68903f169668488909942f27c91289a6ba14d9.zip
Bump deepseq to 1.3.0.1
Package-Manager: portage-2.1.11.14/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/deepseq/deepseq-1.3.0.1.ebuild')
-rw-r--r--dev-haskell/deepseq/deepseq-1.3.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/deepseq/deepseq-1.3.0.1.ebuild b/dev-haskell/deepseq/deepseq-1.3.0.1.ebuild
new file mode 100644
index 000000000000..ab6168a883a3
--- /dev/null
+++ b/dev-haskell/deepseq/deepseq-1.3.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/deepseq/deepseq-1.3.0.1.ebuild,v 1.1 2012/09/14 10:52:08 gienah Exp $
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal versionator
+
+MY_P="${P/_pre*/}"
+
+DESCRIPTION="Deep evaluation of data structures"
+HOMEPAGE="http://hackage.haskell.org/package/deepseq"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+CABAL_CORE_LIB_GHC_PV="7.6.* 7.7.*"