summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-05-14 01:46:59 +0000
committerRyan Hill <rhill@gentoo.org>2007-05-14 01:46:59 +0000
commit68d02a576b5ec203cfd81e4e94bbfcad8f78589f (patch)
tree9f338b79f94401f6eeb5af9ddc85b236d861ba4e /dev-games/crystalspace/crystalspace-1.0.1.ebuild
parentMask =www-client/opera-9.21 until it goes into beta. (diff)
downloadhistorical-68d02a576b5ec203cfd81e4e94bbfcad8f78589f.tar.gz
historical-68d02a576b5ec203cfd81e4e94bbfcad8f78589f.tar.bz2
historical-68d02a576b5ec203cfd81e4e94bbfcad8f78589f.zip
Lock to wxGTK-2.6 and use wxwidgets.eclass.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'dev-games/crystalspace/crystalspace-1.0.1.ebuild')
-rw-r--r--dev-games/crystalspace/crystalspace-1.0.1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-games/crystalspace/crystalspace-1.0.1.ebuild b/dev-games/crystalspace/crystalspace-1.0.1.ebuild
index f016d0c6a4eb..031a17a15334 100644
--- a/dev-games/crystalspace/crystalspace-1.0.1.ebuild
+++ b/dev-games/crystalspace/crystalspace-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.1.ebuild,v 1.2 2007/03/04 07:50:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.0.1.ebuild,v 1.3 2007/05/14 01:46:59 dirtyepic Exp $
-inherit flag-o-matic java-pkg-opt-2 multilib
+inherit flag-o-matic java-pkg-opt-2 multilib wxwidgets
MY_P=${PN}-src-${PV}
DESCRIPTION="Portable 3D Game Development Kit written in C++"
@@ -30,7 +30,7 @@ RDEPEND="virtual/opengl
mng? ( media-libs/libmng )
png? ( media-libs/libpng )
wxwindows? ( x11-libs/pango
- >=x11-libs/wxGTK-2.6 )
+ =x11-libs/wxGTK-2.6* )
javascript? ( dev-lang/spidermonkey )
cegui? ( >=dev-games/cegui-0.5.0 )
x11-libs/libXaw
@@ -57,6 +57,14 @@ src_unpack() {
}
src_compile() {
+ if useq wxwindows; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ if [[ ! -e /usr/bin/wx-config ]]; then
+ sed -i -e "s:wx-config:${WX_CONFIG_NAME}:g" configure
+ fi
+ fi
+
# -O3 is hanging compilation of python script plugin
# trying -O2 just in case
replace-flags -O3 -O2