summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-03-11 03:32:28 +0000
committerPeter Johanson <latexer@gentoo.org>2005-03-11 03:32:28 +0000
commit1235e5c3d73130c5ec18caeeae428b989caf2912 (patch)
treec125b10d075a375ec4e7be3d82fce6c50d2513b5 /dev-dotnet/mono/mono-1.0.2.ebuild
parentMove mono from dev-dotnet -> dev-lang (diff)
downloadhistorical-1235e5c3d73130c5ec18caeeae428b989caf2912.tar.gz
historical-1235e5c3d73130c5ec18caeeae428b989caf2912.tar.bz2
historical-1235e5c3d73130c5ec18caeeae428b989caf2912.zip
Moved to dev-lang
Diffstat (limited to 'dev-dotnet/mono/mono-1.0.2.ebuild')
-rw-r--r--dev-dotnet/mono/mono-1.0.2.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-dotnet/mono/mono-1.0.2.ebuild b/dev-dotnet/mono/mono-1.0.2.ebuild
deleted file mode 100644
index 4b4b331a7b41..000000000000
--- a/dev-dotnet/mono/mono-1.0.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-1.0.2.ebuild,v 1.5 2005/01/18 16:38:31 scandium Exp $
-
-inherit eutils mono flag-o-matic debug
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com/"
-SRC_URI="http://www.go-mono.com/archive/${PV}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-2 X11)"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE=""
-
-DEPEND="virtual/libc
- >=dev-libs/glib-2.0
- >=dev-libs/icu-2.6.1
- !<dev-dotnet/pnet-0.6.12
- ppc? ( >=sys-devel/gcc-3.2.3-r4 )
- ppc? ( >=sys-libs/glibc-2.3.3_pre20040420 )"
-RDEPEND="${DEPEND}
- dev-util/pkgconfig
- dev-libs/libxml2"
-
-src_compile() {
- strip-flags
-
- if have_NPTL
- then
- eerror "mono currently has bug in garbage collection when"
- eerror "using a NPTL enabled glibc. Please see bug #54603"
- eerror "on bugs.gentoo.org for details. You can use the"
- eerror "package.masked mono-1.0.2-r1 release if you need NPTL"
- eerror "but you have been warned of the problems."
- die "NPTL glibc not support by this release"
- fi
-
- econf --with-tls=pthread || die
- emake -j1 || die "MONO compilation failure"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- dodoc AUTHORS ChangeLog NEWS README
- docinto docs
- dodoc docs/*
- docinto libgc
- dodoc libgc/ChangeLog
-
- # init script
- exeinto /etc/init.d ; newexe ${FILESDIR}/dotnet.init dotnet
- insinto /etc/conf.d ; newins ${FILESDIR}/dotnet.conf dotnet
-}
-
-pkg_postinst() {
- echo
- einfo "If you want to avoid typing '<runtime> program.exe'"
- einfo "you can configure your runtime in /etc/conf.d/dotnet"
- einfo "Use /etc/init.d/dotnet to register your runtime"
- echo
-}