summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-24 17:43:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-24 17:43:32 +0000
commit340e3907db7128c461d883ff83eda5fccf534fb5 (patch)
tree71e15a54ef2e2120d8f34009761ef20384137ebc /dev-db
parent*** empty log message *** (diff)
downloadhistorical-340e3907db7128c461d883ff83eda5fccf534fb5.tar.gz
historical-340e3907db7128c461d883ff83eda5fccf534fb5.tar.bz2
historical-340e3907db7128c461d883ff83eda5fccf534fb5.zip
*** empty log message ***
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.1_beta31
-rw-r--r--dev-db/postgresql/postgresql-7.1_beta3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/postgresql/files/digest-postgresql-7.1_beta3 b/dev-db/postgresql/files/digest-postgresql-7.1_beta3
new file mode 100644
index 000000000000..b9ec4395fc3d
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.1_beta3
@@ -0,0 +1 @@
+MD5 ad2b3b181753e902c4857fada6c01158 postgresql-7.1beta3.tar.gz
diff --git a/dev-db/postgresql/postgresql-7.1_beta3.ebuild b/dev-db/postgresql/postgresql-7.1_beta3.ebuild
new file mode 100644
index 000000000000..73c5572a8336
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.1_beta3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r1.ebuild,v 1.4 2001/01/23 19:54:43 achim Exp
+
+P=postgresql-7.1beta3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.postgresql.org/pub/dev/${A}"
+HOMEPAGE="http://postgresql.readysetnet.com/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/backend/catalog
+ cp genbki.sh genbki.sh.orig
+# sed -e 's:\\name:\\ name:' genbki.sh.orig > genbki.sh
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --datadir=/usr/share/postgres --includedir=/usr/include/postgres \
+ --enable-locale --with-tcl --enable-syslog
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr includedir=${D}/usr/include/postgres \
+ datadir=${D}/usr/share/postgres install
+}
+