summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-08-13 10:34:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-08-13 10:34:29 +0000
commit703471c6541d036529914c25ed404e03078333a7 (patch)
treebab1ab746788c55bbe614aa6848459a7a021aa2c /dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild
parentVersion Bump sat4j-*. (diff)
downloadhistorical-703471c6541d036529914c25ed404e03078333a7.tar.gz
historical-703471c6541d036529914c25ed404e03078333a7.tar.bz2
historical-703471c6541d036529914c25ed404e03078333a7.zip
Bump, lots of nice fixes by Johan Bergstroem, fixes #331555
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild')
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild
new file mode 100644
index 000000000000..50f6dd04cde1
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.46.ebuild,v 1.1 2010/08/13 10:34:29 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/${PV}.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-off64
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}