summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-17 09:40:42 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-17 09:40:42 +0000
commit3430f9b0740f2e42e867b3e3467187083b8463fd (patch)
tree62709569bbafa887f733faba19bf2d4a9aa9f7b2 /dev-db/postgresql/postgresql-7.4.14.ebuild
parentStable on ppc wrt bug #157744. (diff)
downloadhistorical-3430f9b0740f2e42e867b3e3467187083b8463fd.tar.gz
historical-3430f9b0740f2e42e867b3e3467187083b8463fd.tar.bz2
historical-3430f9b0740f2e42e867b3e3467187083b8463fd.zip
Dropped old versions. Added note for people having the pg-hier USE-flag set.
Package-Manager: portage-2.1.2_rc3
Diffstat (limited to 'dev-db/postgresql/postgresql-7.4.14.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-7.4.14.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-db/postgresql/postgresql-7.4.14.ebuild b/dev-db/postgresql/postgresql-7.4.14.ebuild
index 201960076c57..9b0f30124509 100644
--- a/dev-db/postgresql/postgresql-7.4.14.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.14.ebuild,v 1.8 2006/12/17 08:08:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.14.ebuild,v 1.9 2006/12/17 09:40:42 dev-zero Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs versionator
@@ -47,7 +47,17 @@ pkg_setup() {
eerror "(database directory = ${PG_DIR})."
die "Remove your database directory to continue"
fi
+ if built_with_use dev-db/postgresql pg-hier ; then
+ eerror "The hier-patch has been dropped and your existing database"
+ eerror "can't be used without it. You have to use pg_dump to export your"
+ eerror "existing database cluster, move ${PG_DIR}/data away and then use"
+ eerror "pg_restore to re-create the database using the new version."
+ eerror "Sorry for the inconvience. Please open a bug if you really need"
+ eerror "the hier-patch."
+ die "Move your database directory to continue."
+ fi
fi
+
enewgroup postgres 70
enewuser postgres 70 /bin/bash /var/lib postgres
}