summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-04-19 20:37:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-04-19 20:37:13 +0000
commite9d60995e12a94d7577ef0218bab66e3b362264b (patch)
treeffa449cbe6ae1be75be23b0a1cf5bf1276a73c81 /dev-db/postgresql-server/files
parentrm old version (diff)
downloadhistorical-e9d60995e12a94d7577ef0218bab66e3b362264b.tar.gz
historical-e9d60995e12a94d7577ef0218bab66e3b362264b.tar.bz2
historical-e9d60995e12a94d7577ef0218bab66e3b362264b.zip
Updated patch for 8.3 (accidentally disabled tsearch2, thanks to Elvis Pranskevichus). Corrected a bug in init.d scripts.
Package-Manager: portage-2.1.5_rc4
Diffstat (limited to 'dev-db/postgresql-server/files')
-rw-r--r--dev-db/postgresql-server/files/postgresql-8.3-server.patch4
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-7.317
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-7.424
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-8.017
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-8.117
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-8.217
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-8.317
7 files changed, 73 insertions, 40 deletions
diff --git a/dev-db/postgresql-server/files/postgresql-8.3-server.patch b/dev-db/postgresql-server/files/postgresql-8.3-server.patch
index 756127c5d188..6b04efa41610 100644
--- a/dev-db/postgresql-server/files/postgresql-8.3-server.patch
+++ b/dev-db/postgresql-server/files/postgresql-8.3-server.patch
@@ -26,7 +26,7 @@
==================================================================
--- contrib/Makefile (revision 12)
+++ contrib/Makefile (local)
-@@ -20,22 +20,18 @@
+@@ -20,22 +20,19 @@
isn \
lo \
ltree \
@@ -44,7 +44,7 @@
spi \
tablefunc \
- test_parser \
-- tsearch2 \
+ tsearch2 \
- vacuumlo
+ test_parser
diff --git a/dev-db/postgresql-server/files/postgresql.init-7.3 b/dev-db/postgresql-server/files/postgresql.init-7.3
index 0c852763e270..833387bc3169 100644
--- a/dev-db/postgresql-server/files/postgresql.init-7.3
+++ b/dev-db/postgresql-server/files/postgresql.init-7.3
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-7.3,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-7.3,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -40,20 +40,25 @@ start() {
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +66,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?
diff --git a/dev-db/postgresql-server/files/postgresql.init-7.4 b/dev-db/postgresql-server/files/postgresql.init-7.4
index cdb11581fb2d..b5ec7093069f 100644
--- a/dev-db/postgresql-server/files/postgresql.init-7.4
+++ b/dev-db/postgresql-server/files/postgresql.init-7.4
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-7.4,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-7.4,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -25,6 +25,8 @@ checkconfig() {
start() {
checkconfig || return 1
+ local retval
+
ebegin "Starting PostgreSQL"
if [ -f "$PGDATA/postmaster.pid" ] ; then
@@ -33,27 +35,33 @@ start() {
su -l ${PGUSER} \
-c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-7.4/bin/pg_ctl start -w -o '--silent-mode=true ${PGOPTS}'"
-
- eend $?
+ retval=$?
+ echo $retval
+ eend $retval
}
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +69,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?
diff --git a/dev-db/postgresql-server/files/postgresql.init-8.0 b/dev-db/postgresql-server/files/postgresql.init-8.0
index b02d1e6450ea..a6840b3ef314 100644
--- a/dev-db/postgresql-server/files/postgresql.init-8.0
+++ b/dev-db/postgresql-server/files/postgresql.init-8.0
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.0,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.0,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -40,20 +40,25 @@ start() {
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +66,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?
diff --git a/dev-db/postgresql-server/files/postgresql.init-8.1 b/dev-db/postgresql-server/files/postgresql.init-8.1
index 5d498e0cddc4..b277eee1742f 100644
--- a/dev-db/postgresql-server/files/postgresql.init-8.1
+++ b/dev-db/postgresql-server/files/postgresql.init-8.1
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.1,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.1,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -40,20 +40,25 @@ start() {
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +66,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?
diff --git a/dev-db/postgresql-server/files/postgresql.init-8.2 b/dev-db/postgresql-server/files/postgresql.init-8.2
index 212a4ca3fd3a..8dd4c4f59893 100644
--- a/dev-db/postgresql-server/files/postgresql.init-8.2
+++ b/dev-db/postgresql-server/files/postgresql.init-8.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.2,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.2,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -40,20 +40,25 @@ start() {
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +66,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?
diff --git a/dev-db/postgresql-server/files/postgresql.init-8.3 b/dev-db/postgresql-server/files/postgresql.init-8.3
index a936c7296167..e284ddc58a6e 100644
--- a/dev-db/postgresql-server/files/postgresql.init-8.3
+++ b/dev-db/postgresql-server/files/postgresql.init-8.3
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.3,v 1.1 2008/04/15 09:29:55 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-8.3,v 1.2 2008/04/19 20:37:13 dev-zero Exp $
opts="${opts} reload"
@@ -40,20 +40,25 @@ start() {
stop() {
ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+ local retval
+
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -TERM/${WAIT_FOR_DISCONNECT}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
ewarn "Going to shutdown the server anyway."
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -INT/${WAIT_FOR_CLEANUP}
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
eerror "Server did not shut down and sending the SIGQUIT has been disabled."
- eend $?
+ eend $retval
+ return $retval
fi
ewarn "Shutting down the server gracefully failed."
@@ -61,8 +66,8 @@ stop() {
start-stop-daemon --stop --pidfile "${PGDATA}/postmaster.pid" \
--retry -QUIT/${WAIT_FOR_QUIT}
-
- [ $? -eq 0 ] && eend $? && exit
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
eend $?