summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-16 21:13:29 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-16 21:13:29 +0000
commit377b8a0bbbe76a53527915f6db63b559fbef53f2 (patch)
tree5e63d7355deeff1687358769604e531db2c405ff /dev-db/postgis
parentremoved without-x. Fixes #11221. Submitted by Jason Rhinelander. (diff)
downloadhistorical-377b8a0bbbe76a53527915f6db63b559fbef53f2.tar.gz
historical-377b8a0bbbe76a53527915f6db63b559fbef53f2.tar.bz2
historical-377b8a0bbbe76a53527915f6db63b559fbef53f2.zip
new package - support for geographic objects to PostgreSQL
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/ChangeLog10
-rw-r--r--dev-db/postgis/files/digest-postgis-0.7.32
-rw-r--r--dev-db/postgis/files/postgis-0.7.3-gentoo.diff11
-rw-r--r--dev-db/postgis/postgis-0.7.3.ebuild72
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/postgis/ChangeLog b/dev-db/postgis/ChangeLog
new file mode 100644
index 000000000000..62b5b4a9ad33
--- /dev/null
+++ b/dev-db/postgis/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/postgis
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/ChangeLog,v 1.1 2002/12/16 21:13:29 george Exp $
+
+*postgis-0.7.3.ebuild (16 äÅË 2002)
+
+ 16 äÅË 2002; George Shapovalov <george@gentoo.org> ChangeLog, postgis-0.7.3.ebuild, files/\{postgis-0.7.3-gentoo.diff\} :
+ initial release
+ adds support for geographic objects to PostgreSQL
+ ebuild submitted by Nathaniel C. Domingo <nathaniel.domingo@upd.edu.ph>
diff --git a/dev-db/postgis/files/digest-postgis-0.7.3 b/dev-db/postgis/files/digest-postgis-0.7.3
new file mode 100644
index 000000000000..465f824d9957
--- /dev/null
+++ b/dev-db/postgis/files/digest-postgis-0.7.3
@@ -0,0 +1,2 @@
+MD5 7a84327daf1f546609a6eaa58f409064 postgis-0.7.3.tar.gz 301713
+MD5 cf665c93a08a60e4a99db3a6dfe7ba10 postgresql-7.2.3.tar.gz 9244039
diff --git a/dev-db/postgis/files/postgis-0.7.3-gentoo.diff b/dev-db/postgis/files/postgis-0.7.3-gentoo.diff
new file mode 100644
index 000000000000..92d08e05c3cb
--- /dev/null
+++ b/dev-db/postgis/files/postgis-0.7.3-gentoo.diff
@@ -0,0 +1,11 @@
+--- Makefile 2002-09-05 08:07:18.000000000 +0800
++++ Makefile.2 2002-11-30 14:21:32.000000000 +0800
+@@ -2,7 +2,7 @@
+
+ #---------------------------------------------------------------
+ # Set USE_PROJ to 1 for Proj4 reprojection support
+-USE_PROJ=0
++USE_PROJ=1
+
+ #---------------------------------------------------------------
+ subdir=contrib/postgis
diff --git a/dev-db/postgis/postgis-0.7.3.ebuild b/dev-db/postgis/postgis-0.7.3.ebuild
new file mode 100644
index 000000000000..3675eb94ad94
--- /dev/null
+++ b/dev-db/postgis/postgis-0.7.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-0.7.3.ebuild,v 1.1 2002/12/16 21:13:29 george Exp $
+
+IUSE=""
+
+S="${WORKDIR}/${P}"
+MY_PGSQL="postgresql-7.2.3"
+
+DESCRIPTION="adds support for geographic objects to PostgreSQL"
+SRC_URI="http://postgis.refractions.net/${P}.tar.gz
+ ftp://ftp8.us.postgresql.org/pub/pgsql/source/v7.2.3/${MY_PGSQL}.tar.gz"
+HOMEPAGE="http://postgis.refractions.net"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="=postgresql-7.2.3-r1
+ dev-libs/proj"
+
+src_unpack() {
+ unpack "${MY_PGSQL}.tar.gz"
+ cd ${MY_PGSQL}/contrib
+ unpack "${P}.tar.gz"
+ cd "${P}"
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
+ local myconf
+ cd "${WORKDIR}/${MY_PGSQL}"
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="${myconf} --with-python"
+ use perl && myconf="${myconf} --with-perl"
+ use java && myconf="${myconf} --with-java"
+ use ssl && myconf="${myconf} --with-ssl"
+ use nls && myconf="${myconf} --enable-locale --enable-nls --enable-multibyte"
+ use libg++ && myconf="${myconf} --with-CXX"
+
+ use ppc && CFLAGS="-pipe-fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${MY_PGSQL}-r1 \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-pam \
+ --with-maxbackends=1024 \
+ ${myconf} || die
+
+ cd contrib/${P}
+
+ make || die
+}
+
+src_install () {
+
+ cd ${WORKDIR}/${MY_PGSQL}/contrib/${P}
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${MY_PGSQL} \
+ libdir=${D}/usr/lib/contrib \
+ install || die
+
+ dodoc CHANGES COPYING CREDITS TODO
+}