summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-29 08:09:53 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-29 08:09:53 +0000
commitd6588d6b93b518c617e0affc90a29f36f0fec5cc (patch)
tree58a5702f67e2e320a100d269542eb98dd3c78891 /dev-db/pgtune/pgtune-0.9.3.ebuild
parentVersion bump, drop old (diff)
downloadhistorical-d6588d6b93b518c617e0affc90a29f36f0fec5cc.tar.gz
historical-d6588d6b93b518c617e0affc90a29f36f0fec5cc.tar.bz2
historical-d6588d6b93b518c617e0affc90a29f36f0fec5cc.zip
Initial import, ebuild by me
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'dev-db/pgtune/pgtune-0.9.3.ebuild')
-rw-r--r--dev-db/pgtune/pgtune-0.9.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/pgtune/pgtune-0.9.3.ebuild b/dev-db/pgtune/pgtune-0.9.3.ebuild
new file mode 100644
index 000000000000..dd6f306dc78e
--- /dev/null
+++ b/dev-db/pgtune/pgtune-0.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgtune/pgtune-0.9.3.ebuild,v 1.1 2012/08/29 08:09:53 patrick Exp $
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A postgresql settings tuning wizard"
+
+HOMEPAGE="http://pgfoundry.org/projects/pgtune/"
+SRC_URI="http://pgfoundry.org/frs/download.php/2449/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+RDEPEND="dev-lang/python"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/share/doc/${P}
+ cp "${S}/pgtune" "${D}/usr/bin/pgtune" || die
+ for i in COPYRIGHT README TODO pg_settings-8.4-32 pg_settings-8.4-64 pgtune-settingsdir.patch pgtune.spec postgresql.conf.sample; do
+ cp "${S}/${i}" "${D}/usr/share/doc/${P}" || die
+ done
+ docompress -x /usr/share/doc
+}