summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-10-20 06:02:17 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-10-20 06:02:17 +0000
commite87c5a54362538711a29862188cbed7e9ad07a43 (patch)
tree4387dca7a56b9d447da7c76f13bfb4eaad297db7 /dev-cpp/libbackend-elements
parentInitial commit (ebuild written by me), needed for xsd and the required librar... (diff)
downloadhistorical-e87c5a54362538711a29862188cbed7e9ad07a43.tar.gz
historical-e87c5a54362538711a29862188cbed7e9ad07a43.tar.bz2
historical-e87c5a54362538711a29862188cbed7e9ad07a43.zip
Initial commit (ebuild written by me), needed for xsd and the required libraries.
Package-Manager: portage-2.2_rc94/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/libbackend-elements')
-rw-r--r--dev-cpp/libbackend-elements/ChangeLog11
-rw-r--r--dev-cpp/libbackend-elements/libbackend-elements-1.7.0.ebuild69
-rw-r--r--dev-cpp/libbackend-elements/metadata.xml9
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-cpp/libbackend-elements/ChangeLog b/dev-cpp/libbackend-elements/ChangeLog
new file mode 100644
index 000000000000..553922d749b4
--- /dev/null
+++ b/dev-cpp/libbackend-elements/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-cpp/libbackend-elements
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libbackend-elements/ChangeLog,v 1.1 2010/10/20 05:56:23 dev-zero Exp $
+
+*libbackend-elements-1.7.0 (20 Oct 2010)
+
+ 20 Oct 2010; Tiziano Müller <dev-zero@gentoo.org>
+ +libbackend-elements-1.7.0.ebuild, +metadata.xml:
+ Initial commit (ebuild written by me), needed for xsd and the required
+ libraries.
+
diff --git a/dev-cpp/libbackend-elements/libbackend-elements-1.7.0.ebuild b/dev-cpp/libbackend-elements/libbackend-elements-1.7.0.ebuild
new file mode 100644
index 000000000000..db6aa0c2c1ac
--- /dev/null
+++ b/dev-cpp/libbackend-elements/libbackend-elements-1.7.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libbackend-elements/libbackend-elements-1.7.0.ebuild,v 1.1 2010/10/20 05:56:23 dev-zero Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of elementary building blocks for implementing compiler backends in c++."
+HOMEPAGE="http://kolpackov.net/projects/libbackend-elements/"
+SRC_URI="ftp://kolpackov.net/pub/projects/${PN}/${PV%.?}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-cpp/libcult-1.4.3
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-util/build"
+
+src_configure() {
+ mkdir -p build/{c,cxx/gnu,import/libboost,import/libcult}
+
+ cat >> build/c/configuration-lib-dynamic.make <<- EOF
+c_lib_type := shared
+ EOF
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/import/libboost/configuration-dynamic.make <<- EOF
+libboost_installed := y
+ EOF
+
+ cat >> build/import/libcult/configuration-dynamic.make <<- EOF
+libcult_installed := y
+ EOF
+}
+
+src_install() {
+ find backend-elements -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf backend-elements/arch
+
+ insinto /usr/include
+ doins -r backend-elements
+
+ dodoc NEWS README
+ dohtml -A xhtml -r documentation/*
+}
diff --git a/dev-cpp/libbackend-elements/metadata.xml b/dev-cpp/libbackend-elements/metadata.xml
new file mode 100644
index 000000000000..9f8438a7910f
--- /dev/null
+++ b/dev-cpp/libbackend-elements/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>