summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-26 09:51:32 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-26 09:51:32 +0000
commita2a5bfc61779eb120e6cf8e5d9b16d460c8ccda6 (patch)
tree86c4d2908244b3b0e2a651d9f2d30fd60767c7e6 /dev-cpp/ctemplate
parentVersion bump. (diff)
downloadhistorical-a2a5bfc61779eb120e6cf8e5d9b16d460c8ccda6.tar.gz
historical-a2a5bfc61779eb120e6cf8e5d9b16d460c8ccda6.tar.bz2
historical-a2a5bfc61779eb120e6cf8e5d9b16d460c8ccda6.zip
Remove old.
Package-Manager: portage-2.2.0_alpha77/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog6
-rw-r--r--dev-cpp/ctemplate/ctemplate-0.99.ebuild72
-rw-r--r--dev-cpp/ctemplate/files/ctemplate-0.99-gcc-4.6.patch10
3 files changed, 5 insertions, 83 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 78cd8d32d7e1..d9cb6dc53dd3 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.13 2011/09/03 04:21:59 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.14 2011/11/26 09:51:32 radhermit Exp $
+
+ 26 Nov 2011; Tim Harder <radhermit@gentoo.org> -ctemplate-0.99.ebuild,
+ -files/ctemplate-0.99-gcc-4.6.patch:
+ Remove old.
*ctemplate-1.0 (03 Sep 2011)
diff --git a/dev-cpp/ctemplate/ctemplate-0.99.ebuild b/dev-cpp/ctemplate/ctemplate-0.99.ebuild
deleted file mode 100644
index a704ef7c0564..000000000000
--- a/dev-cpp/ctemplate/ctemplate-0.99.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.99.ebuild,v 1.3 2011/04/29 09:53:34 radhermit Exp $
-
-EAPI="3"
-
-inherit elisp-common eutils
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="http://code.google.com/p/google-ctemplate/"
-SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs"
-
-DEPEND=""
-RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
- emacs? ( virtual/emacs )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc-4.6.patch
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use emacs ; then
- elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # Installs just every piece
- rm -rf "${ED}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README
- use doc && dohtml doc/*
-
- if use vim-syntax ; then
- cd "${S}/contrib"
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/*
- fi
-
- if use emacs ; then
- cd "${S}/contrib"
- elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-cpp/ctemplate/files/ctemplate-0.99-gcc-4.6.patch b/dev-cpp/ctemplate/files/ctemplate-0.99-gcc-4.6.patch
deleted file mode 100644
index 8495e7a6e3d1..000000000000
--- a/dev-cpp/ctemplate/files/ctemplate-0.99-gcc-4.6.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ctemplate-0.99.orig/src/ctemplate/template_dictionary.h.in
-+++ ctemplate-0.99/src/ctemplate/template_dictionary.h.in
-@@ -54,6 +54,7 @@
- #include <map>
- #include <string>
- #include <vector>
-+#include <cstddef>
- #include <ctemplate/template_dictionary_interface.h>
- #include <ctemplate/template_string.h>
- #include <ctemplate/template_modifiers.h>