summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-11-16 17:16:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-11-16 17:16:48 +0000
commite20c8d590388429fa1c2b0897b082163ea3b218c (patch)
tree7d939db245ceec7a9b5594ba72d0304e82e6c8e0 /dev-cpp/asio
parentVersion bumped. (diff)
downloadhistorical-e20c8d590388429fa1c2b0897b082163ea3b218c.tar.gz
historical-e20c8d590388429fa1c2b0897b082163ea3b218c.tar.bz2
historical-e20c8d590388429fa1c2b0897b082163ea3b218c.zip
Added recursive-init patch, bug #153514 - thanks to Jack Lloyd. Dropped old version.
Package-Manager: portage-2.1.2_rc1-r5
Diffstat (limited to 'dev-cpp/asio')
-rw-r--r--dev-cpp/asio/ChangeLog8
-rw-r--r--dev-cpp/asio/asio-0.3.7.ebuild22
-rw-r--r--dev-cpp/asio/files/asio-0.3.7-recursive_init.patch17
3 files changed, 39 insertions, 8 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index b0b18aab2a2b..641886583d68 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/asio
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.5 2006/10/18 21:44:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.6 2006/11/16 17:16:48 dev-zero Exp $
+
+ 16 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
+ +files/asio-0.3.7-recursive_init.patch, -asio-0.3.4.ebuild,
+ asio-0.3.7.ebuild:
+ Added recursive-init patch, bug #153514 - thanks to Jack Lloyd. Dropped old
+ version.
18 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
Version bump.
diff --git a/dev-cpp/asio/asio-0.3.7.ebuild b/dev-cpp/asio/asio-0.3.7.ebuild
index 54279d24b55f..6695408d8139 100644
--- a/dev-cpp/asio/asio-0.3.7.ebuild
+++ b/dev-cpp/asio/asio-0.3.7.ebuild
@@ -1,19 +1,27 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-0.3.7.ebuild,v 1.1 2006/10/18 21:44:45 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-0.3.7.ebuild,v 1.2 2006/11/16 17:16:48 dev-zero Exp $
+
+inherit eutils
+
+KEYWORDS="~x86"
DESCRIPTION="asynchronous network library"
HOMEPAGE="http://asio.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
LICENSE="Boost-1.0"
SLOT="0"
-KEYWORDS="~x86"
-IUSE="doc ssl test"
+IUSE="doc ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.33.0"
+RDEPEND="${DEPEND}"
-DEPEND=">=dev-libs/boost-1.33.0
- test? ( ssl? ( dev-libs/openssl ) )"
-RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-recursive_init.patch"
+}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
diff --git a/dev-cpp/asio/files/asio-0.3.7-recursive_init.patch b/dev-cpp/asio/files/asio-0.3.7-recursive_init.patch
new file mode 100644
index 000000000000..20f5e2aaba7a
--- /dev/null
+++ b/dev-cpp/asio/files/asio-0.3.7-recursive_init.patch
@@ -0,0 +1,17 @@
+--- ./include/asio/ssl/detail/openssl_init.hpp.orig 2006-11-15 00:10:08.000000000 +0100
++++ ./include/asio/ssl/detail/openssl_init.hpp 2006-11-15 00:10:38.000000000 +0100
+@@ -45,13 +45,13 @@
+ {
+ ::SSL_library_init();
+ ::SSL_load_error_strings();
++ ::OpenSSL_add_ssl_algorithms();
+
+ mutexes_.resize(::CRYPTO_num_locks());
+ for (size_t i = 0; i < mutexes_.size(); ++i)
+ mutexes_[i].reset(new asio::detail::mutex);
+ ::CRYPTO_set_locking_callback(&do_init::openssl_locking_func);
+
+- ::OpenSSL_add_ssl_algorithms();
+ }
+ }
+