summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 00:47:53 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 00:47:53 +0000
commit98c65c05700e688e54fa0b99e368d776b161771b (patch)
treefa48694c8f9331aaa8704bb84dc06437df88b132 /app-text
parent*** empty log message *** (diff)
downloadhistorical-98c65c05700e688e54fa0b99e368d776b161771b.tar.gz
historical-98c65c05700e688e54fa0b99e368d776b161771b.tar.bz2
historical-98c65c05700e688e54fa0b99e368d776b161771b.zip
*** empty log message ***
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ggv/ggv-1.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/ggv/ggv-1.0.1.ebuild b/app-text/ggv/ggv-1.0.1.ebuild
new file mode 100644
index 000000000000..ef0577012d90
--- /dev/null
+++ b/app-text/ggv/ggv-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-apps/ggv/ggv-0.95-r1.ebuild,v 1.2 2001/02/01 19:30:33 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gnome-libs-1.2.4
+ bonobo? ( >=gnome-base/bonobo-1.0 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND=">=gnome-base/gnome-libs-1.2.4
+ bonobo? ( >=gnome-base/bonobo-1.0 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ else
+ myconf="$myconf --without-bonobo"
+ cp configure configure.orig
+ sed -e "s/BONOBO_TRUE/BONOBO_FALSE/" configure.orig > configure
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ $myconf
+ # bonobo support does not work yet
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+