summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 23:01:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 23:01:40 +0000
commit81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca (patch)
treece1e8d5cd3f24ff3f7abcc462541cd14ac8492a7 /app-text
parentChange XVendorString to be compatible with upstream so people can strstr for ... (diff)
downloadhistorical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.tar.gz
historical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.tar.bz2
historical-81512dd6b12dc6f43c09c7cdb92f2c398fd8c2ca.zip
add inherit eutils
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmltidy/htmltidy-2.7.18-r2.ebuild18
-rw-r--r--app-text/htmltidy/htmltidy-3.10.29.ebuild20
-rw-r--r--app-text/kbarcode/kbarcode-1.7.2.ebuild9
-rw-r--r--app-text/lout/lout-3.25-r1.ebuild6
-rw-r--r--app-text/openjade/openjade-1.3.2-r1.ebuild17
-rw-r--r--app-text/pep/pep-2.8.ebuild10
-rw-r--r--app-text/ptex/ptex-3.1.3.ebuild11
-rw-r--r--app-text/rman/rman-3.1.ebuild15
-rw-r--r--app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild15
-rw-r--r--app-text/tetex/tetex-1.0.7-r13.ebuild12
-rw-r--r--app-text/tetex/tetex-2.0.2-r3.ebuild4
-rw-r--r--app-text/tkman/tkman-2.1-r1.ebuild16
-rw-r--r--app-text/tkman/tkman-2.2.ebuild16
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild4
-rw-r--r--app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild4
-rw-r--r--app-text/unix2dos/unix2dos-2.2.ebuild10
-rw-r--r--app-text/xmlto/xmlto-0.0.15.ebuild22
-rw-r--r--app-text/xmlto/xmlto-0.0.17.ebuild25
-rw-r--r--app-text/xpdf/xpdf-3.00-r1.ebuild6
19 files changed, 111 insertions, 129 deletions
diff --git a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
index e375099132c8..2f5f61ffd4a6 100644
--- a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
+++ b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.1 2003/12/20 05:23:52 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.2 2004/04/08 22:53:10 vapier Exp $
+
+inherit eutils
# convert from normalized gentoo version number to htmltidy's wacky date thing
parts=(${PV//./ })
@@ -9,36 +11,31 @@ MY_P=tidy_src_${vers}
S=${WORKDIR}/tidy
DESCRIPTION="Tidy the layout and correct errors in HTML and XML documents"
+HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz"
-HOMEPAGE="http://tidy.sourceforge.net/"
-LICENSE="GPL-2"
-IUSE="xml doc"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="xml doc"
DEPEND=""
src_unpack() {
-
unpack ${A}
cd ${S}
use xml && epatch ${FILESDIR}/htmltidy-dbpatch.diff
# Prevent tidy from chown/grp'ing itself to 'tidy:tidy'
sed -i -e "s:chgrp\|chown:#&:" Makefile
-
}
src_compile() {
-
emake OTHERCFLAGS="${CFLAGS}" || die "emake failed"
-
}
src_install() {
-
# Need to move the man page around, thanks to the flaky Makefile
cp ${S}/htmldoc/man_page.txt ${S}/man_page.txt
@@ -51,5 +48,4 @@ src_install() {
dohtml *.html *.gif *.css
# and the api documentation if we have USE="doc"
use doc && dohtml -r api
-
}
diff --git a/app-text/htmltidy/htmltidy-3.10.29.ebuild b/app-text/htmltidy/htmltidy-3.10.29.ebuild
index de1791a83766..caaf2fae5af1 100644
--- a/app-text/htmltidy/htmltidy-3.10.29.ebuild
+++ b/app-text/htmltidy/htmltidy-3.10.29.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.7 2004/02/27 21:19:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.8 2004/04/08 22:53:45 vapier Exp $
+
+inherit eutils
# Convert gentoo version number x.y.z to date xyz for
# tidy's source numbering by date
@@ -14,14 +16,13 @@ HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz
xml? ( http://www.cise.ufl.edu/~ppadala/tidy/html2db.tar.gz )"
-LICENSE="GPL-2"
-IUSE="debug doc xml"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~amd64"
+IUSE="debug doc xml"
src_unpack() {
-
unpack ${A}
cd ${S}
# Required to setup the source dist for autotools
@@ -32,7 +33,7 @@ src_unpack() {
# Stop tidy from appending -O2 to our CFLAGS
sed -i -e "/save_cflags/s/\ \-O2//" configure.in
- if [ `use xml` ]; then
+ if use xml ; then
# Apply the docbook patch to tidy sources
epatch ${FILESDIR}/03-${PN}-docbook.patch
@@ -44,26 +45,21 @@ src_unpack() {
sed -i -e "/TIDYDIR\=/s:\.\.:${S}:" \
-e "/LIBDIR\=/s:lib:src\/\.libs\/:" \
${WORKDIR}/html2db/Makefile
-
fi
-
}
src_compile() {
-
export WANT_AUTOMAKE=1.5 WANT_AUTOCONF=2.5
econf `use_enable debug` || die
emake || die
- if [ `use xml` ]; then
+ if use xml ; then
cd ${WORKDIR}/html2db
make || die
fi
-
}
src_install() {
-
make DESTDIR=${D} install || die
use xml && dobin ${WORKDIR}/html2db/html2db
@@ -79,6 +75,4 @@ src_install() {
# If use 'doc' is set, then we also want to install the
# api documentation
use doc && dohtml -r api
-
}
-
diff --git a/app-text/kbarcode/kbarcode-1.7.2.ebuild b/app-text/kbarcode/kbarcode-1.7.2.ebuild
index 32f6e529e479..aa992ba9704b 100644
--- a/app-text/kbarcode/kbarcode-1.7.2.ebuild
+++ b/app-text/kbarcode/kbarcode-1.7.2.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbarcode/kbarcode-1.7.2.ebuild,v 1.3 2004/03/07 09:50:49 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbarcode/kbarcode-1.7.2.ebuild,v 1.4 2004/04/08 22:54:03 vapier Exp $
-inherit kde
+inherit kde eutils
need-kde 3
-IUSE="imagemagick"
DESCRIPTION="A KDE 3.x solution for barcode handling."
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.kbarcode.net/"
+
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="imagemagick"
DEPEND=">=kde-base/kdelibs-3
>=app-text/barcode-0.98"
-
RDEPEND="${DEPEND}
imagemagick? ( media-gfx/imagemagick )"
@@ -22,4 +22,3 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-default-parameter.patch
}
-
diff --git a/app-text/lout/lout-3.25-r1.ebuild b/app-text/lout/lout-3.25-r1.ebuild
index 8ebdb9c127f4..0009da83eb0d 100644
--- a/app-text/lout/lout-3.25-r1.ebuild
+++ b/app-text/lout/lout-3.25-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.25-r1.ebuild,v 1.8 2004/03/12 09:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.25-r1.ebuild,v 1.9 2004/04/08 22:54:20 vapier Exp $
+
+inherit eutils
DESCRIPTION="high-level language for document formatting"
HOMEPAGE="http://snark.ptc.spbu.ru/~uwe/lout/"
SRC_URI="http://www.tex.ac.uk/tex-archive/support/lout/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc"
SLOT="0"
+KEYWORDS="x86 sparc"
DEPEND=">=sys-libs/zlib-1.1.4"
RDEPEND=""
diff --git a/app-text/openjade/openjade-1.3.2-r1.ebuild b/app-text/openjade/openjade-1.3.2-r1.ebuild
index 167b32396ec4..b28235c9645b 100644
--- a/app-text/openjade/openjade-1.3.2-r1.ebuild
+++ b/app-text/openjade/openjade-1.3.2-r1.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.14 2004/03/21 07:58:40 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.15 2004/04/08 22:55:20 vapier Exp $
-inherit libtool sgml-catalog
+inherit libtool sgml-catalog eutils
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="Jade is an implemetation of DSSSL - an ISO standard for formatting SGML and XML documents"
-SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
HOMEPAGE="http://openjade.sourceforge.net"
-SLOT="0"
+SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
+
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="ia64 x86 amd64 hppa ~ppc alpha sparc mips"
+IUSE=""
RDEPEND="app-text/sgml-common
>=app-text/opensp-1.5-r1"
-
DEPEND="dev-lang/perl
${RDEPEND}"
-KEYWORDS="ia64 x86 amd64 hppa ~ppc alpha sparc mips"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -57,7 +55,6 @@ src_compile() {
}
src_install() {
-
dodir /usr
dodir /usr/lib
make prefix=${D}/usr \
diff --git a/app-text/pep/pep-2.8.ebuild b/app-text/pep/pep-2.8.ebuild
index e7de0b69be1d..49e5da076093 100644
--- a/app-text/pep/pep-2.8.ebuild
+++ b/app-text/pep/pep-2.8.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.2 2004/03/15 15:37:06 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.3 2004/04/08 22:55:45 vapier Exp $
+
+inherit eutils
DESCRIPTION="Pep is a general purpose filter and file cleaning program"
HOMEPAGE="http://folk.uio.no/gisle/enjoy/pep.html"
SRC_URI="http://folk.uio.no/gisle/enjoy/${PN}${PV//./}.zip"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
+
DEPEND="app-arch/unzip
virtual/glibc"
RDEPEND="virtual/glibc"
@@ -18,7 +21,6 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
-
# pep does not come with autconf so here's a patch to configure
# Makefile with the correct path
epatch ${FILESDIR}/${P}-gentoo.patch || die "epatch failed"
@@ -31,7 +33,7 @@ src_compile() {
}
src_install() {
- dobin pep
+ dobin pep || die
doman Doc/pep.1
insinto /usr/share/pep
diff --git a/app-text/ptex/ptex-3.1.3.ebuild b/app-text/ptex/ptex-3.1.3.ebuild
index a1ad173459f0..ca7d585e6f14 100644
--- a/app-text/ptex/ptex-3.1.3.ebuild
+++ b/app-text/ptex/ptex-3.1.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.3.ebuild,v 1.5 2004/03/14 21:02:47 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.3.ebuild,v 1.6 2004/04/08 22:56:07 vapier Exp $
PTEX_TEXMF_PV=2.1
TETEX_PV=2.0.2
-inherit tetex
+inherit tetex eutils
DESCRIPTION="The ASCII publishing TeX distribution"
HOMEPAGE="http://www.ascii.co.jp/pb/ptex/"
@@ -19,14 +19,13 @@ SRC_URI="${SRC_URI}
${SRC_PATH_PTEX}/tetex/${PTEX_TEXMF}
${SRC_PATH_PTEX}/dvips/dvipsk-jpatch-p1.6.tar.gz"
-KEYWORDS="x86 alpha amd64 ~sparc"
-SLOT="0"
LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="x86 alpha amd64 ~sparc"
PDEPEND="app-text/xdvik"
src_unpack() {
-
tetex_src_unpack
einfo "Unpacking pTeX sources..."
@@ -42,7 +41,6 @@ src_unpack() {
}
src_compile() {
-
tetex_src_compile
cat >>${S}/texk/web2c/fmtutil.cnf<<-EOF
@@ -65,7 +63,6 @@ src_compile() {
}
src_install() {
-
tetex_src_install
einfo "Installing pTeX..."
diff --git a/app-text/rman/rman-3.1.ebuild b/app-text/rman/rman-3.1.ebuild
index 8e58bead745c..e8e9c495c6cc 100644
--- a/app-text/rman/rman-3.1.ebuild
+++ b/app-text/rman/rman-3.1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.1.ebuild,v 1.3 2004/03/12 08:49:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.1.ebuild,v 1.4 2004/04/08 22:56:33 vapier Exp $
+
+inherit eutils
DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
-SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
HOMEPAGE="http://polyglotman.sourceforge.net/"
-KEYWORDS="x86 ppc sparc"
-SLOT="0"
+SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
+
LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
DEPEND=""
@@ -21,7 +24,7 @@ src_compile() {
emake CFLAGS="${CFLAGS} -finline-functions" || die "make failed"
}
-src_install () {
- dobin ${PN}
+src_install() {
+ dobin ${PN} || die
doman ${PN}.1
}
diff --git a/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild b/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild
index 426b0078edf8..8b78f069c150 100644
--- a/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild
+++ b/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild
@@ -1,26 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild,v 1.9 2004/03/14 18:05:08 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/scrollkeeper/scrollkeeper-0.3.14.ebuild,v 1.10 2004/04/08 22:57:08 vapier Exp $
-IUSE="nls"
-
-inherit libtool
+inherit libtool eutils
-S=${WORKDIR}/${P}
DESCRIPTION="ScrollKeeper is a cataloging system for documentation on open systems."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://scrollkeeper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="FDL-1.1 LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa ~amd64 ia64 ~mips"
+IUSE="nls"
RDEPEND=">=dev-libs/libxml2-2.4.19
>=dev-libs/libxslt-1.0.14
>=sys-libs/zlib-1.1.3
=app-text/docbook-xml-dtd-4.1.2*
>=app-text/docbook-sgml-utils-0.6.6"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.29
nls? ( sys-devel/gettext )"
@@ -29,7 +26,7 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p0< ${FILESDIR}/${P}-gentoo.diff || die
+ epatch ${FILESDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-gcc2_fix.patch
}
diff --git a/app-text/tetex/tetex-1.0.7-r13.ebuild b/app-text/tetex/tetex-1.0.7-r13.ebuild
index 4b414d7b6071..a0f47225a739 100644
--- a/app-text/tetex/tetex-1.0.7-r13.ebuild
+++ b/app-text/tetex/tetex-1.0.7-r13.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-1.0.7-r13.ebuild,v 1.8 2004/02/21 12:17:18 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-1.0.7-r13.ebuild,v 1.9 2004/04/08 22:58:31 vapier Exp $
+
+inherit eutils flag-o-matic
TEXMFSRC="teTeX-texmf-gg-1.0.3.tar.bz2"
S=${WORKDIR}/teTeX-1.0
DESCRIPTION="a complete TeX distribution"
+HOMEPAGE="http://tug.org/teTeX/"
SRC_URI="ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/1.0/distrib/sources/teTeX-src-${PV}.tar.gz
ftp://ftp.dante.de/pub/tex/systems/unix/teTeX/1.0/contrib/ghibo/${TEXMFSRC}
mirror://gentoo/ec-ready-mf-tfm.tar.gz
mirror://teTeX-french.tar.gz"
-HOMEPAGE="http://tug.org/teTeX/"
KEYWORDS="x86 ppc sparc alpha hppa"
SLOT="0"
@@ -81,8 +83,7 @@ src_unpack() {
}
src_compile() {
-
- filter-flags "-fstack-protector"
+ filter-flags -fstack-protector
local myconf=""
use X \
@@ -113,7 +114,6 @@ src_compile() {
}
src_install() {
-
dodir /usr/share/
# Install texmf files
einfo "Installing texmf..."
@@ -163,7 +163,6 @@ src_install() {
}
pkg_postinst() {
-
if [ $ROOT = "/" ]
then
einfo "Configuring teTeX..."
@@ -186,4 +185,3 @@ pkg_postinst() {
echo
fi
}
-
diff --git a/app-text/tetex/tetex-2.0.2-r3.ebuild b/app-text/tetex/tetex-2.0.2-r3.ebuild
index 40c4b2661f94..4d6d285f1234 100644
--- a/app-text/tetex/tetex-2.0.2-r3.ebuild
+++ b/app-text/tetex/tetex-2.0.2-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-2.0.2-r3.ebuild,v 1.10 2004/04/06 02:59:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-2.0.2-r3.ebuild,v 1.11 2004/04/08 22:58:41 vapier Exp $
-inherit tetex
+inherit tetex eutils
DESCRIPTION="a complete TeX distribution"
HOMEPAGE="http://tug.org/teTeX/"
diff --git a/app-text/tkman/tkman-2.1-r1.ebuild b/app-text/tkman/tkman-2.1-r1.ebuild
index 190fdcb20d76..54e0681be6f5 100644
--- a/app-text/tkman/tkman-2.1-r1.ebuild
+++ b/app-text/tkman/tkman-2.1-r1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tkman/tkman-2.1-r1.ebuild,v 1.8 2004/03/12 08:50:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tkman/tkman-2.1-r1.ebuild,v 1.9 2004/04/08 22:59:09 vapier Exp $
+
+inherit eutils
DESCRIPTION="TkMan man and info page browser"
-SRC_URI="http://tkman.sourceforge.net/${PN}.tar.gz"
HOMEPAGE="http://tkman.sourceforge.net/"
-KEYWORDS="x86 ppc sparc"
-SLOT="0"
+SRC_URI="http://tkman.sourceforge.net/${PN}.tar.gz"
+
LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
DEPEND=">=app-text/rman-3.0.9
>=dev-lang/tcl-8.3.3
@@ -22,14 +25,13 @@ src_unpack() {
has_version '>=sys-apps/groff-1.18' \
has_version '<app-text/rman-3.1' \
&& sed -i -e "s:groff -te -Tlatin1:groff -P -c -te -Tlatin1:" ${S}/Makefile
-
}
src_compile() {
emake || die
}
-src_install () {
- dobin ${PN}
+src_install() {
+ dobin ${PN} || die
dobin re${PN}
}
diff --git a/app-text/tkman/tkman-2.2.ebuild b/app-text/tkman/tkman-2.2.ebuild
index 776249fcaa24..612ea22ffef0 100644
--- a/app-text/tkman/tkman-2.2.ebuild
+++ b/app-text/tkman/tkman-2.2.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tkman/tkman-2.2.ebuild,v 1.4 2004/03/12 08:50:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tkman/tkman-2.2.ebuild,v 1.5 2004/04/08 22:59:32 vapier Exp $
+
+inherit eutils
DESCRIPTION="TkMan man and info page browser"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://tkman.sourceforge.net/"
-KEYWORDS="~x86 ~ppc ~sparc"
-SLOT="0"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
IUSE=""
DEPEND=">=app-text/rman-3.1
@@ -24,9 +27,8 @@ src_compile() {
emake || die
}
-src_install () {
- mkdir -p ${D}/usr/bin
-
+src_install() {
+ dodir /usr/bin
make DESTDIR=${D} install || die
dodoc ANNOUNCE-tkman.txt CHANGES README-tkman manual.html
diff --git a/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild b/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
index 2f894aae83b1..27a31a87eaf0 100644
--- a/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
+++ b/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild,v 1.17 2004/03/12 09:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.3.3.ebuild,v 1.18 2004/04/08 22:59:57 vapier Exp $
+
+inherit eutils
DESCRIPTION="Converts True Type to Type 1 fonts"
HOMEPAGE="http://ttf2pt1.sourceforge.net/"
diff --git a/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild b/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild
index 34ebffb54373..425d7264cd07 100644
--- a/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild
+++ b/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild,v 1.15 2004/03/12 09:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ttf2pt1/ttf2pt1-3.4.0.ebuild,v 1.16 2004/04/08 23:00:07 vapier Exp $
+
+inherit eutils
DESCRIPTION="Converts True Type to Type 1 fonts"
HOMEPAGE="http://ttf2pt1.sourceforge.net/"
diff --git a/app-text/unix2dos/unix2dos-2.2.ebuild b/app-text/unix2dos/unix2dos-2.2.ebuild
index c5d70a70f861..8ab6f57213de 100644
--- a/app-text/unix2dos/unix2dos-2.2.ebuild
+++ b/app-text/unix2dos/unix2dos-2.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2.ebuild,v 1.8 2004/03/10 20:18:42 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2.ebuild,v 1.9 2004/04/08 23:00:32 vapier Exp $
-DESCRIPTION="unix2dos - UNIX to DOS text file format converter"
+inherit gcc eutils
+
+DESCRIPTION="UNIX to DOS text file format converter"
HOMEPAGE=""
SRC_URI="mirror://gentoo/${P}.src.tar.gz"
@@ -23,10 +25,10 @@ src_unpack() {
}
src_compile() {
- gcc ${CFLAGS} -o unix2dos unix2dos.c || die
+ $(gcc-getCC) ${CFLAGS} -o unix2dos unix2dos.c || die
}
src_install() {
- dobin unix2dos
+ dobin unix2dos || die
doman unix2dos.1
}
diff --git a/app-text/xmlto/xmlto-0.0.15.ebuild b/app-text/xmlto/xmlto-0.0.15.ebuild
index 05bc55004868..36493bb66ece 100644
--- a/app-text/xmlto/xmlto-0.0.15.ebuild
+++ b/app-text/xmlto/xmlto-0.0.15.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.15.ebuild,v 1.15 2004/01/14 20:45:44 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.15.ebuild,v 1.16 2004/04/08 23:00:58 vapier Exp $
+
+inherit eutils
DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
HOMEPAGE="http://cyberelk.net/tim/xmlto/"
SRC_URI="http://cyberelk.net/tim/data/${PN}/stable/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86 ~ppc sparc alpha ia64 hppa"
+IUSE=""
DEPEND="app-shells/bash
dev-libs/libxslt
@@ -19,30 +21,20 @@ DEPEND="app-shells/bash
# Passivetex/xmltex need some sorting out, we'll include pdf/dvi/tex
# support in the first revision to xmlto <obz@gentoo.org>
-# not parrallel safe, thanks <agriffis@gentoo.org>, bug #33151
-MAKEOPTS="${MAKEOPTS} -j1"
-
src_unpack() {
-
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PN}-head-fix.patch
-
}
src_compile() {
-
econf || die
- emake || die
-
+ emake -j1 || die
}
src_install() {
-
make DESTDIR=${D} prefix="/usr" install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
insinto /usr/share/doc/${P}/xml
doins doc/*.xml
-
}
-
diff --git a/app-text/xmlto/xmlto-0.0.17.ebuild b/app-text/xmlto/xmlto-0.0.17.ebuild
index 6a32673beec8..f14285f20bb4 100644
--- a/app-text/xmlto/xmlto-0.0.17.ebuild
+++ b/app-text/xmlto/xmlto-0.0.17.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.17.ebuild,v 1.5 2004/03/16 04:47:56 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.17.ebuild,v 1.6 2004/04/08 23:01:23 vapier Exp $
+
+inherit eutils
DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
HOMEPAGE="http://cyberelk.net/tim/xmlto/"
SRC_URI="http://cyberelk.net/tim/data/${PN}/stable/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="~x86 ppc ~sparc ~alpha ~ia64 amd64 ~mips"
+IUSE=""
DEPEND="app-shells/bash
dev-libs/libxslt
@@ -18,29 +20,20 @@ DEPEND="app-shells/bash
# tetex? ( >=app-text/passivetex-1.4 )"
# Passivetex/xmltex need some sorting out <obz@gentoo.org>
-# not parrallel safe, thanks <agriffis@gentoo.org>, bug #33151
-MAKEOPTS="${MAKEOPTS} -j1"
-
src_unpack() {
-
- unpack ${A}; cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${PN}-head-fix.patch
-
}
src_compile() {
-
econf || die
- emake || die
-
+ emake -j1 || die
}
src_install() {
-
make DESTDIR=${D} prefix="/usr" install || die
- dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README
insinto /usr/share/doc/${P}/xml
doins doc/*.xml
-
}
-
diff --git a/app-text/xpdf/xpdf-3.00-r1.ebuild b/app-text/xpdf/xpdf-3.00-r1.ebuild
index 032d32908b04..9b53a8321d09 100644
--- a/app-text/xpdf/xpdf-3.00-r1.ebuild
+++ b/app-text/xpdf/xpdf-3.00-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r1.ebuild,v 1.1 2004/03/14 13:30:41 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r1.ebuild,v 1.2 2004/04/08 23:01:40 vapier Exp $
+
+inherit eutils
DESCRIPTION="An X Viewer for PDF Files"
HOMEPAGE="http://www.foolabs.com/xpdf/"
@@ -30,7 +32,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
prepallman
- dodoc README ANNOUNCE CHANGES COPYING
+ dodoc README ANNOUNCE CHANGES
insinto /etc
doins ${FILESDIR}/xpdfrc
}