summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-12-09 16:28:20 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-12-09 16:28:20 +0000
commit1d097b4761fe738bdf7995027b0dfaee7af35bf8 (patch)
tree6c0273b9ed168ad6e6999efb5763c04652523955 /app-text
parenthppa support (diff)
downloadhistorical-1d097b4761fe738bdf7995027b0dfaee7af35bf8.tar.gz
historical-1d097b4761fe738bdf7995027b0dfaee7af35bf8.tar.bz2
historical-1d097b4761fe738bdf7995027b0dfaee7af35bf8.zip
virtual/ghostscript, .so build
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript-afpl/ChangeLog6
-rw-r--r--app-text/ghostscript-afpl/Manifest4
-rw-r--r--app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild14
3 files changed, 18 insertions, 6 deletions
diff --git a/app-text/ghostscript-afpl/ChangeLog b/app-text/ghostscript-afpl/ChangeLog
index d31d8c18a3f3..9593f9432570 100644
--- a/app-text/ghostscript-afpl/ChangeLog
+++ b/app-text/ghostscript-afpl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript-afpl
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-afpl/ChangeLog,v 1.1 2003/12/08 14:18:06 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-afpl/ChangeLog,v 1.2 2003/12/09 16:28:14 lanius Exp $
+
+ 09 Dec 2003; Heinrich Wendel <lanius@gentoo.org>
+ ghostscript-afpl-8.11.ebuild:
+ added installation of dynamic libraries, provide virtual/ghostscript
*ghostscript-afpl-8.11 (08 Dec 2003)
diff --git a/app-text/ghostscript-afpl/Manifest b/app-text/ghostscript-afpl/Manifest
index 846cd4d7e180..505e630b99cb 100644
--- a/app-text/ghostscript-afpl/Manifest
+++ b/app-text/ghostscript-afpl/Manifest
@@ -1,5 +1,5 @@
-MD5 3d2baaa781b90f719222850f24ad9c55 ghostscript-afpl-8.11.ebuild 3056
-MD5 cd6be8d50fe01cad604a32c3ef06de53 ChangeLog 412
+MD5 bd8890653bbaaa5a35289cf23f69a5c9 ghostscript-afpl-8.11.ebuild 3278
+MD5 2a71ac8887d59d7a361d77f817d281bb ChangeLog 567
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 c2ae99630b9c6264495d16e128e82fd8 files/digest-ghostscript-afpl-8.11 359
MD5 dbdb3cd0aea8f9032baa11bc335d181a files/gs-8.11-ijs.patch 757
diff --git a/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild b/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild
index 55275c6756c0..87815c64e31f 100644
--- a/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild
+++ b/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild,v 1.1 2003/12/08 14:18:06 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-afpl/ghostscript-afpl-8.11.ebuild,v 1.2 2003/12/09 16:28:14 lanius Exp $
inherit eutils
@@ -19,6 +19,8 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="X cups cjk"
+PROVIDE="virtual/ghostscript"
+
DEPEND="virtual/glibc
>=media-libs/jpeg-6b
>=media-libs/libpng-1.2.1
@@ -28,7 +30,8 @@ DEPEND="virtual/glibc
media-fonts/kochi-substitute
media-fonts/baekmuk-fonts )
cups? ( >=net-print/cups-1.1.20 )
- !app-text/ghostscript"
+ gtk? ( =x11-libs/gtk+-1.2* )
+ !virtual/ghostscript"
S=${WORKDIR}/${MY_P}
@@ -61,6 +64,9 @@ src_compile() {
use X && myconf="${myconf} --with-x" \
|| myconf="${myconf} --without-x"
+ use gtk || sed -i -e 's:$(INSTALL_PROGRAM) $(GSSOX):#:' src/unix-dll.mak \
+ -e 's:$(GSSOX)::' src/unix-dll.mak
+
econf ${myconf}
use cups && echo 'include pstoraster/cups.mak' >> Makefile; sed -i -e 's:DEVICE_DEVS17=:DEVICE_DEVS17=$(DD)cups.dev:' Makefile
@@ -74,6 +80,7 @@ src_compile() {
use cups && sed -i -e 's:LDFLAGS=$(XLDFLAGS):LDFLAGS=-L/usr/include -lcups -lcupsimage $(XLDFLAGS):' Makefile
make || die "make failed"
+ make so || die "make so failed"
cd ijs
econf --prefix=${D}/usr
@@ -82,7 +89,7 @@ src_compile() {
}
src_install() {
- einstall install_prefix=${D}
+ einstall install_prefix=${D} soinstall
cd ${WORKDIR}
cp -a fonts ${D}/usr/share/ghostscript || die
@@ -107,4 +114,5 @@ src_install() {
cd ${S}/ijs
dodir /usr/bin /usr/include /usr/lib
einstall install_prefix=${D}
+ die
}